zabbix: version bump to 2.0.5

Signed-off-by: Jiri Slachta <slachta@cesnet.cz>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@35636 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
juhosg 2013-02-17 12:13:42 +00:00
parent 15469568db
commit d3bfeaa109
4 changed files with 11 additions and 12 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2006-2012 OpenWrt.org
# Copyright (C) 2006-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=zabbix
PKG_VERSION:=2.0.3
PKG_VERSION:=2.0.5
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/zabbix
PKG_MD5SUM:=bef75dd149abc8a6da4adafc08eb61de
PKG_MD5SUM:=0c0721c31889b63bce9aa556bcb927e8
PKG_INSTALL:=1

View File

@ -1,6 +1,6 @@
--- a/configure.in 2012-06-21 21:32:23.707912790 +0000
+++ b/configure.in 2012-06-21 21:33:36.213554564 +0000
@@ -806,25 +806,8 @@
@@ -802,25 +802,8 @@
dnl Check for %qu format (FreeBSD 4.x)
dnl FreeBSD 4.x does not support %llu

View File

@ -1,7 +1,7 @@
--- a/configure.in 2012-05-21 14:07:37.000000000 +0000
+++ b/configure.in 2012-06-21 19:46:34.843662509 +0000
--- a/configure.in 2013-02-14 18:29:28.145419003 +0100
+++ b/configure.in 2013-02-14 18:28:42.873418092 +0100
@@ -149,6 +149,10 @@
AC_MSG_ERROR([Unable to DNS lookup functions "${found_resolv}"])
AC_MSG_ERROR([Unable to do DNS lookups (libresolv check failed)])
fi
LIBS="${LIBS} ${RESOLV_LIBS}"
+AC_SEARCH_LIBS([res_mkquery], [], [AC_DEFINE([HAVE_RES_MKQUERY], 1, [Define if res_mkquery exists])])

View File

@ -1,7 +1,6 @@
diff -urN zabbix-1.6/src/libs/zbxsysinfo/linux/cpu.c zabbix-1.6.new/src/libs/zbxsysinfo/linux/cpu.c
--- zabbix-1.6/src/libs/zbxsysinfo/linux/cpu.c 2008-09-18 22:15:26.000000000 +0200
+++ zabbix-1.6.new/src/libs/zbxsysinfo/linux/cpu.c 2008-09-30 19:32:54.000000000 +0200
@@ -22,6 +22,45 @@
--- a/src/libs/zbxsysinfo/linux/cpu.c 2013-02-12 12:27:22.000000000 +0100
+++ b/src/libs/zbxsysinfo/linux/cpu.c 2013-02-14 18:38:02.517429349 +0100
@@ -21,6 +21,45 @@
#include "sysinfo.h"
#include "stats.h"
@ -46,4 +45,4 @@ diff -urN zabbix-1.6/src/libs/zbxsysinfo/linux/cpu.c zabbix-1.6.new/src/libs/zbx
+
int SYSTEM_CPU_NUM(const char *cmd, const char *param, unsigned flags, AGENT_RESULT *result)
{
char mode[128];
char tmp[16];