[packages] xtables-addons: update to v1.22 and fix compile against iptables 1.4.6

git-svn-id: svn://svn.openwrt.org/openwrt/packages@19318 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2010-01-24 20:41:44 +00:00
parent 54831f9306
commit d776e011e0
3 changed files with 9 additions and 33 deletions

View File

@ -9,11 +9,11 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=xtables-addons
PKG_VERSION:=1.18
PKG_VERSION:=1.22
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_MD5SUM:=5a8d2edbf5a3470bba58d6a60c350805
PKG_MD5SUM:=990e2d84a1767c8247c92ae7b11e53a9
PKG_SOURCE_URL:=@SF/xtables-addons
PKG_BUILD_DEPENDS:=iptables
@ -39,6 +39,7 @@ define Build/Compile
CROSS_COMPILE="$(TARGET_CROSS)" \
DESTDIR="$(PKG_INSTALL_DIR)" \
DEPMOD="/bin/true" \
LDFLAGS="$(TARGET_LDFLAGS)" \
all install
endef

View File

@ -1,11 +1,12 @@
--- a/Makefile.in
+++ b/Makefile.in
@@ -753,7 +753,7 @@ install-dvi: install-dvi-recursive
@@ -751,8 +751,7 @@
install-dvi-am:
-install-exec-am: install-exec-local
+install-exec-am:
install-exec-am:
- @$(NORMAL_INSTALL)
- $(MAKE) $(AM_MAKEFLAGS) install-exec-hook
+
install-html: install-html-recursive
install-html-am:

View File

@ -1,26 +0,0 @@
--- a/extensions/GNUmakefile.in
+++ b/extensions/GNUmakefile.in
@@ -2,8 +2,8 @@
top_srcdir := @top_srcdir@
srcdir := @srcdir@
-abstop_srcdir := $(shell readlink -f ${top_srcdir})
-abssrcdir := $(shell readlink -f ${srcdir})
+abstop_srcdir := $(shell cd ${top_srcdir} && pwd)
+abssrcdir := $(shell cd ${srcdir} && pwd)
ifeq (${abstop_srcdir},)
$(error Path resolution of ${top_srcdir} failed)
--- a/extensions/ipset/GNUmakefile.in
+++ b/extensions/ipset/GNUmakefile.in
@@ -3,8 +3,8 @@
top_srcdir := @top_srcdir@
srcdir := @srcdir@
datarootdir := @datarootdir@
-abstop_srcdir := $(shell readlink -f ${top_srcdir})
-abssrcdir := $(shell readlink -f ${srcdir})
+abstop_srcdir := $(shell cd ${top_srcdir} && pwd)
+abssrcdir := $(shell cd ${srcdir} && pwd)
ifeq (${abstop_srcdir},)
$(error Path resolution of ${top_srcdir} failed)