Update miniupnpd: 1.0-RC5 > 1.0-RC6
git-svn-id: svn://svn.openwrt.org/openwrt/packages@7802 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
9a512f3978
commit
d7830540a3
@ -9,11 +9,11 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=miniupnpd
|
PKG_NAME:=miniupnpd
|
||||||
PKG_VERSION:=1.0-RC5
|
PKG_VERSION:=1.0-RC6
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=2
|
||||||
PKG_MD5SUM:=fce12f92178409f0026a635d4bb5d8be
|
PKG_MD5SUM:=6cb5f0710050b5be0d976383985b012b
|
||||||
|
|
||||||
PKG_SOURCE_URL:=http://miniupnp.tuxfamily.org/files
|
PKG_SOURCE_URL:=http://miniupnp.free.fr/files
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_CAT:=zcat
|
PKG_CAT:=zcat
|
||||||
|
|
||||||
|
@ -1,5 +1,7 @@
|
|||||||
--- miniupnpd-1.0-RC4/Makefile.openwrt.orig 2007-04-26 14:46:51.000000000 -0500
|
Index: miniupnpd-1.0-RC6/Makefile.openwrt
|
||||||
+++ miniupnpd-1.0-RC4/Makefile.openwrt 2007-04-26 14:52:55.000000000 -0500
|
===================================================================
|
||||||
|
--- miniupnpd-1.0-RC6.orig/Makefile.openwrt 2007-06-30 18:30:56.000000000 +0200
|
||||||
|
+++ miniupnpd-1.0-RC6/Makefile.openwrt 2007-06-30 18:30:57.000000000 +0200
|
||||||
@@ -2,7 +2,7 @@
|
@@ -2,7 +2,7 @@
|
||||||
# http://miniupnp.free.fr/
|
# http://miniupnp.free.fr/
|
||||||
# Author : Thomas Bernard
|
# Author : Thomas Bernard
|
||||||
|
@ -1,12 +1,13 @@
|
|||||||
diff -urN miniupnpd.orig/linux/iptables_init.sh miniupnpd/linux/iptables_init.sh
|
Index: miniupnpd-1.0-RC6/linux/iptables_init.sh
|
||||||
--- miniupnpd.orig/linux/iptables_init.sh 2007-04-13 10:02:22.291113712 -0500
|
===================================================================
|
||||||
+++ miniupnpd/linux/iptables_init.sh 2007-04-13 10:04:33.346190312 -0500
|
--- miniupnpd-1.0-RC6.orig/linux/iptables_init.sh 2007-06-30 18:30:56.000000000 +0200
|
||||||
|
+++ miniupnpd-1.0-RC6/linux/iptables_init.sh 2007-06-30 18:30:57.000000000 +0200
|
||||||
@@ -1,9 +1,12 @@
|
@@ -1,9 +1,12 @@
|
||||||
#! /bin/sh
|
#! /bin/sh
|
||||||
# $Id: iptables_init.sh,v 1.3 2006/11/23 12:32:57 nanard Exp $
|
# $Id: iptables_init.sh,v 1.3 2006/11/23 12:32:57 nanard Exp $
|
||||||
+. /etc/functions.sh
|
+. /etc/functions.sh
|
||||||
IPTABLES=iptables
|
IPTABLES=iptables
|
||||||
|
|
||||||
#change this parameters :
|
#change this parameters :
|
||||||
-EXTIF=eth0
|
-EXTIF=eth0
|
||||||
+include /lib/network
|
+include /lib/network
|
||||||
@ -15,20 +16,21 @@ diff -urN miniupnpd.orig/linux/iptables_init.sh miniupnpd/linux/iptables_init.sh
|
|||||||
EXTIP="`LC_ALL=C /sbin/ifconfig $EXTIF | grep 'inet addr' | awk '{print $2}' | sed -e 's/.*://'`"
|
EXTIP="`LC_ALL=C /sbin/ifconfig $EXTIF | grep 'inet addr' | awk '{print $2}' | sed -e 's/.*://'`"
|
||||||
echo "External IP = $EXTIP"
|
echo "External IP = $EXTIP"
|
||||||
|
|
||||||
diff -urN miniupnpd.orig/linux/iptables_removeall.sh miniupnpd/linux/iptables_removeall.sh
|
Index: miniupnpd-1.0-RC6/linux/iptables_removeall.sh
|
||||||
--- miniupnpd.orig/linux/iptables_removeall.sh 2007-04-13 10:01:53.455497392 -0500
|
===================================================================
|
||||||
+++ miniupnpd/linux/iptables_removeall.sh 2007-04-13 10:04:19.444303720 -0500
|
--- miniupnpd-1.0-RC6.orig/linux/iptables_removeall.sh 2007-06-30 18:30:56.000000000 +0200
|
||||||
|
+++ miniupnpd-1.0-RC6/linux/iptables_removeall.sh 2007-06-30 18:30:57.000000000 +0200
|
||||||
@@ -1,9 +1,12 @@
|
@@ -1,9 +1,12 @@
|
||||||
#! /bin/sh
|
#! /bin/sh
|
||||||
# $Id: iptables_removeall.sh,v 1.3 2006/11/23 12:32:57 nanard Exp $
|
# $Id: iptables_removeall.sh,v 1.3 2006/11/23 12:32:57 nanard Exp $
|
||||||
+. /etc/functions.sh
|
+. /etc/functions.sh
|
||||||
IPTABLES=iptables
|
IPTABLES=iptables
|
||||||
|
|
||||||
#change this parameters :
|
#change this parameters :
|
||||||
-EXTIF=eth0
|
-EXTIF=eth0
|
||||||
+include /lib/network
|
+include /lib/network
|
||||||
+scan_interfaces
|
+scan_interfaces
|
||||||
+config_get EXTIF wan ifname
|
+config_get EXTIF wan ifname
|
||||||
EXTIP="`LC_ALL=C /sbin/ifconfig $EXTIF | grep 'inet addr' | awk '{print $2}' | sed -e 's/.*://'`"
|
EXTIP="`LC_ALL=C /sbin/ifconfig $EXTIF | grep 'inet addr' | awk '{print $2}' | sed -e 's/.*://'`"
|
||||||
|
|
||||||
#removing the MINIUPNPD chain for nat
|
#removing the MINIUPNPD chain for nat
|
||||||
|
Loading…
x
Reference in New Issue
Block a user