Add ettercap NG to buildroot-ng
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4790 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
95a51da88e
commit
d81fe15581
59
net/ettercap/Makefile
Normal file
59
net/ettercap/Makefile
Normal file
@ -0,0 +1,59 @@
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id: Makefile 4603 2006-08-18 21:21:06Z mbm $
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ettercap
|
||||
PKG_VERSION:=NG-0.7.3
|
||||
PKG_RELEASE:=0
|
||||
PKG_MD5SUM:=28fb15cd024162c55249888fe1b97820
|
||||
|
||||
PKG_SOURCE_URL:=@SF/ettercap
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/ettercap
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+libpcap +libnet1 +libopenssl +libpcre +libiconv +libncurses
|
||||
TITLE:=Ettercap is a suite for man in the middle attacks on LAN.
|
||||
DESCRIPTION:=Ettercap is a suite for man in the middle attacks on LAN. It features sniffing of live connections,\\\
|
||||
content filtering on the fly and many other interesting tricks.\\\
|
||||
It supports active and passive dissection of many protocols (even ciphered ones) and includes many feature for network\\\
|
||||
and host analysis.\\\
|
||||
URL:=http://ettercap.sourceforge.net
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default,--with-libpcap="$(STAGING_DIR)/usr" \
|
||||
--with-libnet="$(STAGING_DIR)/usr" \
|
||||
--with-openssl="$(STAGING_DIR)/usr" \
|
||||
--with-libpcre="$(STAGING_DIR)/usr" \
|
||||
--with-libiconv="$(STAGING_DIR)/usr" \
|
||||
--with-libncurses="$(STAGING_DIR)/usr" \
|
||||
--disable-gtk \
|
||||
--disable-debug \
|
||||
)
|
||||
endef
|
||||
|
||||
|
||||
define Build/Compile
|
||||
$(call Build/Compile/Default,DESTDIR="$(PKG_INSTALL_DIR)" all install)
|
||||
endef
|
||||
|
||||
define Package/ettercap/install
|
||||
install -d -m0755 $(1)/usr/
|
||||
$(CP) $(PKG_INSTALL_DIR)/* $(1)/
|
||||
rm -rf $(1)/usr/man
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,ettercap))
|
23
net/ettercap/patches/01-cross_compiling.patch
Normal file
23
net/ettercap/patches/01-cross_compiling.patch
Normal file
@ -0,0 +1,23 @@
|
||||
diff -urN ettercap-NG-0.7.3/configure ettercap-NG-0.7.3.new/configure
|
||||
--- ettercap-NG-0.7.3/configure 2005-05-27 17:11:45.000000000 +0200
|
||||
+++ ettercap-NG-0.7.3.new/configure 2006-08-21 20:15:07.000000000 +0200
|
||||
@@ -27354,6 +27354,7 @@
|
||||
|
||||
echo "$as_me:$LINENO: checking for NS_GET32" >&5
|
||||
echo $ECHO_N "checking for NS_GET32... $ECHO_C" >&6
|
||||
+cross_compiling=no
|
||||
if test "$cross_compiling" = yes; then
|
||||
{ { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
|
||||
See \`config.log' for more details." >&5
|
||||
diff -urN ettercap-NG-0.7.3/configure.in ettercap-NG-0.7.3.new/configure.in
|
||||
--- ettercap-NG-0.7.3/configure.in 2005-01-13 10:24:28.000000000 +0100
|
||||
+++ ettercap-NG-0.7.3.new/configure.in 2006-08-21 20:13:29.000000000 +0200
|
||||
@@ -236,7 +236,7 @@
|
||||
AC_CHECK_HEADERS(sys/poll.h poll.h sys/select.h)
|
||||
AC_CHECK_HEADERS(sys/cdefs.h)
|
||||
dnl nameser NS_GET32 and so on...
|
||||
-EC_NS_GET()
|
||||
+#EC_NS_GET()
|
||||
|
||||
dnl ==================================================================
|
||||
dnl Checks for typedefs, structures, and compiler characteristics.
|
Loading…
x
Reference in New Issue
Block a user