Update bluez-utils to 3.36 (#3765)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@11879 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
efb80bbaf3
commit
d84ce95ff5
@ -9,15 +9,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=bluez-utils
|
||||
PKG_VERSION:=3.35
|
||||
PKG_VERSION:=3.36
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://bluez.sourceforge.net/download
|
||||
PKG_MD5SUM:=21dc2f8c03dae9db87da351c735510bb
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
PKG_MD5SUM:=4fc292b635ba7b442c7aaf5680199012
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -43,6 +40,7 @@ CONFIGURE_ARGS += \
|
||||
--enable-network \
|
||||
--enable-usb \
|
||||
--enable-input \
|
||||
--disable-audio \
|
||||
--with-bluez="$(STAGING_DIR)/usr/include" \
|
||||
--with-usb=yes \
|
||||
|
||||
|
@ -1,19 +1,17 @@
|
||||
diff -ur bluez-utils-2.17.orig/hidd/sdp.c bluez-utils-2.17/hidd/sdp.c
|
||||
--- bluez-utils-2.17.orig/hidd/sdp.c 2005-05-09 20:33:24.000000000 +0200
|
||||
+++ bluez-utils-2.17/hidd/sdp.c 2005-07-26 14:38:13.000000000 +0200
|
||||
@@ -39,6 +39,7 @@
|
||||
#include <string.h>
|
||||
--- a/hidd/sdp.c
|
||||
+++ b/hidd/sdp.c
|
||||
@@ -34,6 +34,7 @@
|
||||
#include <sys/stat.h>
|
||||
#include <sys/param.h>
|
||||
#include <sys/socket.h>
|
||||
+#include <linux/limits.h>
|
||||
|
||||
#include <bluetooth/bluetooth.h>
|
||||
#include <bluetooth/l2cap.h>
|
||||
diff -ur bluez-utils-2.17.orig/tools/hciconfig.c bluez-utils-2.17/tools/hciconfig.c
|
||||
--- bluez-utils-2.17.orig/tools/hciconfig.c 2005-05-09 20:33:24.000000000 +0200
|
||||
+++ bluez-utils-2.17/tools/hciconfig.c 2005-07-26 14:34:29.000000000 +0200
|
||||
@@ -40,6 +40,7 @@
|
||||
#include <getopt.h>
|
||||
--- a/tools/hciconfig.c
|
||||
+++ b/tools/hciconfig.c
|
||||
@@ -37,6 +37,7 @@
|
||||
#include <sys/param.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <sys/socket.h>
|
||||
+#include <linux/limits.h>
|
||||
|
@ -1,7 +1,6 @@
|
||||
diff -ur bluez-utils-2.17.orig/hcid/hcid.conf bluez-utils-2.17/hcid/hcid.conf
|
||||
--- bluez-utils-2.17.orig/hcid/hcid.conf 2004-12-25 19:06:00.000000000 +0100
|
||||
+++ bluez-utils-2.17/hcid/hcid.conf 2005-07-26 14:44:23.000000000 +0200
|
||||
@@ -34,7 +34,7 @@
|
||||
--- a/hcid/hcid.conf
|
||||
+++ b/hcid/hcid.conf
|
||||
@@ -29,7 +29,7 @@
|
||||
# Local device name
|
||||
# %d - device id
|
||||
# %h - host name
|
||||
@ -9,4 +8,4 @@ diff -ur bluez-utils-2.17.orig/hcid/hcid.conf bluez-utils-2.17/hcid/hcid.conf
|
||||
+ name "%h";
|
||||
|
||||
# Local device class
|
||||
class 0x3e0100;
|
||||
class 0x000100;
|
||||
|
@ -1,6 +1,5 @@
|
||||
diff -urN bluez-utils-3.24.orig/input/device.c bluez-utils-3.24/input/device.c
|
||||
--- bluez-utils-3.24/input/device.orig 2007-12-08 20:04:42.000000000 +0100
|
||||
+++ bluez-utils-3.24/input/device.c 2008-01-16 09:20:41.000000000 +0100
|
||||
--- a/input/device.c
|
||||
+++ b/input/device.c
|
||||
@@ -25,6 +25,8 @@
|
||||
#include <config.h>
|
||||
#endif
|
||||
@ -10,9 +9,8 @@ diff -urN bluez-utils-3.24.orig/input/device.c bluez-utils-3.24/input/device.c
|
||||
#include <stdlib.h>
|
||||
#include <errno.h>
|
||||
#include <fcntl.h>
|
||||
diff -urN bluez-utils-3.24.orig/input/storage.c bluez-utils-3.24/input/storage.c
|
||||
--- bluez-utils-3.24/input/storage.orig 2007-10-05 09:17:06.000000000 +0200
|
||||
+++ bluez-utils-3.24/input/storage.c 2008-01-16 09:26:23.000000000 +0100
|
||||
--- a/input/storage.c
|
||||
+++ b/input/storage.c
|
||||
@@ -25,6 +25,8 @@
|
||||
#include <config.h>
|
||||
#endif
|
||||
|
@ -1,7 +1,6 @@
|
||||
diff -Naur bluez-utils-3.35.ori/tools/hciattach.c bluez-utils-3.35/tools/hciattach.c
|
||||
--- bluez-utils-3.35.ori/tools/hciattach.c 2008-05-20 18:14:39.000000000 +0200
|
||||
+++ bluez-utils-3.35/tools/hciattach.c 2008-07-06 13:01:28.000000000 +0200
|
||||
@@ -108,20 +108,37 @@
|
||||
--- a/tools/hciattach.c
|
||||
+++ b/tools/hciattach.c
|
||||
@@ -111,20 +111,37 @@
|
||||
return B230400;
|
||||
case 460800:
|
||||
return B460800;
|
||||
|
Loading…
x
Reference in New Issue
Block a user