Update lft to 3.1 (#3631)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@11702 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
78e20efea7
commit
dae60a2158
@ -9,14 +9,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=lft
|
||||
PKG_VERSION:=2.5
|
||||
PKG_VERSION:=3.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://ftp.fredan.se/pub/gentoo.org/distfiles
|
||||
PKG_MD5SUM:=5b0f45addbb371cc076fe6d9d9694546
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_URL:=http://pwhois.org/get
|
||||
PKG_MD5SUM:=70e69706e7600f34c0dfb54e2ee5eb01
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -28,6 +26,15 @@ define Package/lft
|
||||
URL:=http://pwhois.org/lft
|
||||
endef
|
||||
|
||||
define Package/lft/description
|
||||
LFT, short for Layer Four Traceroute, is a sort of 'traceroute' that
|
||||
often works much faster (than the commonly-used Van Jacobson method)
|
||||
and goes through many configurations of packet-filters (firewalls).
|
||||
More importantly, LFT implements numerous other features including AS
|
||||
number lookups through several reliable sources, loose source routing,
|
||||
netblock name lookups, et al.
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default, \
|
||||
--with-pcap="$(STAGING_DIR)/usr" \
|
||||
|
11
net/lft/patches/001-add_pcap_includes.patch
Normal file
11
net/lft/patches/001-add_pcap_includes.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -46,7 +46,7 @@
|
||||
$(CC) -o lft $(OBJS) $(LDFLAGS) $(LIBS)
|
||||
|
||||
whob: whois.o
|
||||
- $(CC) -o whob whois.c -DSTANDALONE $(LDFLAGS) $(LIBS)
|
||||
+ $(CC) -o whob whois.c -DSTANDALONE -I$(STAGING_DIR)/usr/include $(LDFLAGS) $(LIBS)
|
||||
|
||||
install: lft lft.8 whob whob.8
|
||||
@echo "Installing LFT and WhoB"
|
Loading…
x
Reference in New Issue
Block a user