disable building of examples and tests, add libtool fixes
git-svn-id: svn://svn.openwrt.org/openwrt/packages@8637 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
cfa6fd40d5
commit
dbcb6a7d6a
@ -16,9 +16,6 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@GNU/gettext
|
||||
PKG_MD5SUM:=3d9ad24301c6d6b17ec30704a13fe127
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libintl
|
||||
@ -41,11 +38,18 @@ CONFIGURE_ARGS += \
|
||||
--without-libexpat-prefix \
|
||||
--without-emacs
|
||||
|
||||
MAKE_FLAGS += \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default)
|
||||
$(call libtool_disable_rpath)
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) all
|
||||
$(call libtool_fixup_libdir,$(PKG_INSTALL_DIR))
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
mkdir -p $(STAGING_DIR)/usr/lib/libintl/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/libintl.h $(STAGING_DIR)/usr/lib/libintl/include/
|
||||
mkdir -p $(STAGING_DIR)/usr/lib/libintl/lib
|
||||
|
36
libs/gettext/patches/001-no_examples_and_tests.patch
Normal file
36
libs/gettext/patches/001-no_examples_and_tests.patch
Normal file
@ -0,0 +1,36 @@
|
||||
diff -ruN gettext-0.16.1-old/autoconf-lib-link/Makefile.in gettext-0.16.1-new/autoconf-lib-link/Makefile.in
|
||||
--- gettext-0.16.1-old/autoconf-lib-link/Makefile.in 2006-11-27 18:33:54.000000000 +0100
|
||||
+++ gettext-0.16.1-new/autoconf-lib-link/Makefile.in 2007-08-22 21:18:41.000000000 +0200
|
||||
@@ -204,7 +204,7 @@
|
||||
DISTCLEANFILES = build-aux/config.guess build-aux/config.sub \
|
||||
build-aux/install-sh build-aux/ltmain.sh build-aux/missing \
|
||||
build-aux/config.rpath
|
||||
-SUBDIRS = m4 tests
|
||||
+SUBDIRS = m4
|
||||
|
||||
# Subdirectories with separate autoconfiguration.
|
||||
CONFIGURES_RPATHX = $(srcdir)/tests/rpathx/Makefile.in $(srcdir)/tests/rpathx/aclocal.m4 $(srcdir)/tests/rpathx/configure
|
||||
diff -ruN gettext-0.16.1-old/gettext-runtime/Makefile.in gettext-0.16.1-new/gettext-runtime/Makefile.in
|
||||
--- gettext-0.16.1-old/gettext-runtime/Makefile.in 2006-11-27 18:34:14.000000000 +0100
|
||||
+++ gettext-0.16.1-new/gettext-runtime/Makefile.in 2007-08-22 21:18:12.000000000 +0200
|
||||
@@ -140,7 +140,7 @@
|
||||
ETAGS = etags
|
||||
CTAGS = ctags
|
||||
DIST_SUBDIRS = doc intl intl-java intl-csharp gnulib-lib libasprintf \
|
||||
- src po man m4 tests
|
||||
+ src po man m4
|
||||
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
|
||||
distdir = $(PACKAGE)-$(VERSION)
|
||||
top_distdir = $(distdir)
|
||||
diff -ruN gettext-0.16.1-old/gettext-tools/Makefile.in gettext-0.16.1-new/gettext-tools/Makefile.in
|
||||
--- gettext-0.16.1-old/gettext-tools/Makefile.in 2006-11-27 18:34:56.000000000 +0100
|
||||
+++ gettext-0.16.1-new/gettext-tools/Makefile.in 2007-08-22 21:19:11.000000000 +0200
|
||||
@@ -484,7 +484,7 @@
|
||||
top_srcdir = @top_srcdir@
|
||||
AUTOMAKE_OPTIONS = 1.5 gnu no-dependencies
|
||||
ACLOCAL_AMFLAGS = -I m4 -I ../gettext-runtime/m4 -I ../autoconf-lib-link/m4 -I ../m4 -I gnulib-m4 -I libgettextpo/gnulib-m4
|
||||
-SUBDIRS = doc intl gnulib-lib libgrep libuniname src libgettextpo po projects misc man m4 tests examples
|
||||
+SUBDIRS = doc intl gnulib-lib libgrep libuniname src libgettextpo po projects misc man m4
|
||||
|
||||
# Allow users to use "gnulib-tool --update".
|
||||
|
Loading…
x
Reference in New Issue
Block a user