net/bird: update to version 1.2.5

git-svn-id: svn://svn.openwrt.org/openwrt/packages@23638 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
acoul 2010-10-26 11:55:34 +00:00
parent 5868e47f37
commit dc36002bbe
2 changed files with 2 additions and 13 deletions

View File

@ -7,12 +7,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=bird
PKG_VERSION:=1.2.4
PKG_VERSION:=1.2.5
PKG_RELEASE:=1
PKG_SOURCE:=bird-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://bird.network.cz/pub/bird
PKG_MD5SUM:=8db90b12200ebb20f5aa93a2de9937c6
PKG_MD5SUM:=06f330da3290018335d0761549d90226
PKG_BUILD_DEPENDS:=libncurses libreadline
include $(INCLUDE_DIR)/package.mk

View File

@ -1,11 +0,0 @@
--- a/lib/ipv6.c
+++ b/lib/ipv6.c
@@ -73,6 +73,8 @@ ipv6_classify(ip_addr *a)
return IADDR_HOST | SCOPE_LINK;
if ((x & 0xffc00000) == 0xfec00000) /* Site-Local Address */
return IADDR_HOST | SCOPE_SITE;
+ if ((x & 0xfe000000) == 0xfc000000) /* Unique Local Unicast Address (RFC 4193) */
+ return IADDR_HOST | SCOPE_SITE;
if ((x & 0xff000000) == 0xff000000) /* Multicast Address */
{
unsigned int scope = (x >> 16) & 0x0f;