port openh323 to buildroot-ng
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4309 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
555c94c9e0
commit
ddf8612af7
82
libs/openh323/Makefile
Normal file
82
libs/openh323/Makefile
Normal file
@ -0,0 +1,82 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=openh323
|
||||
PKG_VERSION:=cvs-20051230
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://trash.uid0.hu/openwrt/
|
||||
PKG_MD5SUM:=ba1ffd45016f533bec2bb1539b78e43a
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libopenh323
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
DEPENDS:=+pwlib
|
||||
TITLE:=OpenH323 library
|
||||
DESCRIPTION:=OpenH323 library.
|
||||
URL:=http://www.openh323.org/
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
( cd $(PKG_BUILD_DIR); rm -f config.cache; \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti" \
|
||||
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--infodir=/usr/share/info \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
$(DISABLE_NLS) \
|
||||
\
|
||||
--enable-minsize \
|
||||
--enable-audio \
|
||||
--disable-video \
|
||||
);
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
optnoshared
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
ln -sf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR)/$(PKG_NAME)
|
||||
endef
|
||||
|
||||
define Build/UninstallDev
|
||||
rm -rf $(BUILD_DIR)/$(PKG_NAME)
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libopenh323))
|
||||
|
122
libs/openh323/patches/001-configure.patch
Normal file
122
libs/openh323/patches/001-configure.patch
Normal file
@ -0,0 +1,122 @@
|
||||
--- openh323-cvs-20051230.orig/configure 2005-08-30 03:12:38.000000000 +0200
|
||||
+++ openh323-cvs-20051230/configure 2005-12-30 11:29:57.000000000 +0100
|
||||
@@ -3080,10 +3080,10 @@
|
||||
if eval "test \"\${$as_ac_File+set}\" = set"; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
- test "$cross_compiling" = yes &&
|
||||
- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
+# test "$cross_compiling" = yes &&
|
||||
+# { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
+#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
+# { (exit 1); exit 1; }; }
|
||||
if test -r "${PWLIBDIR}/version.h"; then
|
||||
eval "$as_ac_File=yes"
|
||||
else
|
||||
@@ -3104,10 +3104,10 @@
|
||||
if eval "test \"\${$as_ac_File+set}\" = set"; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
- test "$cross_compiling" = yes &&
|
||||
- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
+# test "$cross_compiling" = yes &&
|
||||
+# { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
+#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
+# { (exit 1); exit 1; }; }
|
||||
if test -r "${OPENH323DIR}/../pwlib/version.h"; then
|
||||
eval "$as_ac_File=yes"
|
||||
else
|
||||
@@ -3129,10 +3129,10 @@
|
||||
if eval "test \"\${$as_ac_File+set}\" = set"; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
- test "$cross_compiling" = yes &&
|
||||
- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
+# test "$cross_compiling" = yes &&
|
||||
+# { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
+#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
+# { (exit 1); exit 1; }; }
|
||||
if test -r "${HOME}/pwlib/include/ptlib.h"; then
|
||||
eval "$as_ac_File=yes"
|
||||
else
|
||||
@@ -3153,10 +3153,10 @@
|
||||
if test "${ac_cv_file__usr_local_include_ptlib_h+set}" = set; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
- test "$cross_compiling" = yes &&
|
||||
- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
+# test "$cross_compiling" = yes &&
|
||||
+# { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
+#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
+# { (exit 1); exit 1; }; }
|
||||
if test -r "/usr/local/include/ptlib.h"; then
|
||||
ac_cv_file__usr_local_include_ptlib_h=yes
|
||||
else
|
||||
@@ -3215,10 +3215,10 @@
|
||||
if test "${ac_cv_file__usr_include_ptlib_h+set}" = set; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
- test "$cross_compiling" = yes &&
|
||||
- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
+# test "$cross_compiling" = yes &&
|
||||
+# { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
+#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
+# { (exit 1); exit 1; }; }
|
||||
if test -r "/usr/include/ptlib.h"; then
|
||||
ac_cv_file__usr_include_ptlib_h=yes
|
||||
else
|
||||
@@ -3985,10 +3985,10 @@
|
||||
if test "${ac_cv_file__usr_local_include_ffmpeg_avcodec_h+set}" = set; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
- test "$cross_compiling" = yes &&
|
||||
- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
+# test "$cross_compiling" = yes &&
|
||||
+# { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
+#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
+# { (exit 1); exit 1; }; }
|
||||
if test -r "/usr/local/include/ffmpeg/avcodec.h"; then
|
||||
ac_cv_file__usr_local_include_ffmpeg_avcodec_h=yes
|
||||
else
|
||||
@@ -4193,10 +4193,10 @@
|
||||
if test "${ac_cv_file__usr_local_lib_libvich263_so+set}" = set; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
- test "$cross_compiling" = yes &&
|
||||
- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
+# test "$cross_compiling" = yes &&
|
||||
+# { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
+#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
+# { (exit 1); exit 1; }; }
|
||||
if test -r "/usr/local/lib/libvich263.so"; then
|
||||
ac_cv_file__usr_local_lib_libvich263_so=yes
|
||||
else
|
||||
@@ -4219,10 +4219,10 @@
|
||||
if test "${ac_cv_file__usr_local_include_vich263_encoder_h263_h+set}" = set; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
- test "$cross_compiling" = yes &&
|
||||
- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
- { (exit 1); exit 1; }; }
|
||||
+# test "$cross_compiling" = yes &&
|
||||
+# { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
+#echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
|
||||
+# { (exit 1); exit 1; }; }
|
||||
if test -r "/usr/local/include/vich263/encoder-h263.h"; then
|
||||
ac_cv_file__usr_local_include_vich263_encoder_h263_h=yes
|
||||
else
|
Loading…
x
Reference in New Issue
Block a user