[packages] python: fix compilation against Linux 3.x (#10197)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@29369 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2011-11-30 19:47:24 +00:00
parent 08af67f9c3
commit e14733e4ab
11 changed files with 41 additions and 21 deletions

View File

@ -2,8 +2,8 @@
Makefile.pre.in | 25 +++++++++++++------------
1 file changed, 13 insertions(+), 12 deletions(-)
--- Python-2.6.4.orig/Makefile.pre.in
+++ Python-2.6.4/Makefile.pre.in
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
@@ -175,6 +175,7 @@ UNICODE_OBJS= @UNICODE_OBJS@
PYTHON= python$(EXE)

View File

@ -2,8 +2,8 @@
configure.in | 46 ++++++++++++++++++++++++++++++++++------------
1 file changed, 34 insertions(+), 12 deletions(-)
--- Python-2.6.4.orig/configure.in
+++ Python-2.6.4/configure.in
--- a/configure.in
+++ b/configure.in
@@ -2653,6 +2653,7 @@ AC_CHECK_LIB(c, inet_aton, [$ac_cv_prog_
# On Tru64, chflags seems to be present, but calling it will
# exit Python

View File

@ -0,0 +1,20 @@
--- a/configure
+++ b/configure
@@ -2070,6 +2070,7 @@ then
MACHDEP="$ac_md_system$ac_md_release"
case $MACHDEP in
+ linux3) MACHDEP="linux2";;
cygwin*) MACHDEP="cygwin";;
darwin*) MACHDEP="darwin";;
atheos*) MACHDEP="atheos";;
--- a/configure.in
+++ b/configure.in
@@ -240,6 +240,7 @@ then
MACHDEP="$ac_md_system$ac_md_release"
case $MACHDEP in
+ linux3) MACHDEP="linux2";;
cygwin*) MACHDEP="cygwin";;
darwin*) MACHDEP="darwin";;
atheos*) MACHDEP="atheos";;

View File

@ -2,8 +2,8 @@
Makefile.pre.in | 16 ----------------
1 file changed, 16 deletions(-)
--- Python-2.6.4.orig/Makefile.pre.in
+++ Python-2.6.4/Makefile.pre.in
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
@@ -887,22 +887,6 @@ libinstall: build_all $(srcdir)/Lib/$(PL
done; \
done

View File

@ -2,8 +2,8 @@
setup.py | 15 ++-------------
1 file changed, 2 insertions(+), 13 deletions(-)
--- Python-2.6.4.orig/setup.py
+++ Python-2.6.4/setup.py
--- a/setup.py
+++ b/setup.py
@@ -309,9 +309,6 @@ class PyBuildExt(build_ext):
return sys.platform

View File

@ -2,8 +2,8 @@
setup.py | 30 ------------------------------
1 file changed, 30 deletions(-)
--- Python-2.6.4.orig/setup.py
+++ Python-2.6.4/setup.py
--- a/setup.py
+++ b/setup.py
@@ -270,36 +270,6 @@ class PyBuildExt(build_ext):
ext_filename = os.path.join(
self.build_lib,

View File

@ -2,8 +2,8 @@
Makefile.pre.in | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
--- Python-2.6.4.orig/Makefile.pre.in
+++ Python-2.6.4/Makefile.pre.in
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
@@ -1118,11 +1118,11 @@ TAGS::
# Sanitation targets -- clean leaves libraries, executables and tags
# files, which clobber removes as well

View File

@ -2,8 +2,8 @@
Lib/distutils/command/build_scripts.py | 43 +++------------------------------
1 file changed, 4 insertions(+), 39 deletions(-)
--- Python-2.6.4.orig/Lib/distutils/command/build_scripts.py
+++ Python-2.6.4/Lib/distutils/command/build_scripts.py
--- a/Lib/distutils/command/build_scripts.py
+++ b/Lib/distutils/command/build_scripts.py
@@ -54,10 +54,7 @@ class build_scripts (Command):

View File

@ -2,9 +2,9 @@
Lib/ctypes/__init__.py | 6 ------
1 file changed, 6 deletions(-)
--- Python-2.6.4.orig/Lib/ctypes/__init__.py
+++ Python-2.6.4/Lib/ctypes/__init__.py
@@ -538,9 +538,3 @@ for kind in [c_ushort, c_uint, c_ulong,
--- a/Lib/ctypes/__init__.py
+++ b/Lib/ctypes/__init__.py
@@ -538,9 +538,3 @@ for kind in [c_ushort, c_uint, c_ulong,
elif sizeof(kind) == 4: c_uint32 = kind
elif sizeof(kind) == 8: c_uint64 = kind
del(kind)

View File

@ -2,8 +2,8 @@
Modules/Setup.dist | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
--- Python-2.6.4.orig/Modules/Setup.dist
+++ Python-2.6.4/Modules/Setup.dist
--- a/Modules/Setup.dist
+++ b/Modules/Setup.dist
@@ -460,7 +460,7 @@ GLHACK=-Dclear=__GLclear
# Andrew Kuchling's zlib module.
# This require zlib 1.1.3 (or later).

View File

@ -2,8 +2,8 @@
setup.py | 10 ++++++----
1 file changed, 6 insertions(+), 4 deletions(-)
--- Python-2.6.4.orig/setup.py
+++ Python-2.6.4/setup.py
--- a/setup.py
+++ b/setup.py
@@ -622,9 +622,10 @@ class PyBuildExt(build_ext):
#print 'openssl_ver = 0x%08x' % openssl_ver