[packages] usbip: cleanup dependencies (closes: #8230), fix usb.ids location

git-svn-id: svn://svn.openwrt.org/openwrt/packages@28512 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2011-10-21 23:00:13 +00:00
parent c818416588
commit e1eb5794db
3 changed files with 21 additions and 16 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2010 OpenWrt.org
# Copyright (C) 2010-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -10,13 +10,14 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=usbip
PKG_VERSION:=0.1.7
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/usbip
PKG_MD5SUM:=d1094b6d4449787864f8be001639232c
PKG_FIXUP:=libtool
PKG_BUILD_DEPENDS:=glib2 sysfsutils
PKG_FIXUP:=libtool autoreconf
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
@ -25,7 +26,7 @@ include $(INCLUDE_DIR)/nls.mk
define Package/usbip/Common
TITLE:=USB-over-IP
URL:=http://usbip.sourceforge.net/
DEPENDS:=@!LINUX_2_4 @USB_SUPPORT +glib2 +sysfsutils
DEPENDS:=@!LINUX_2_4 @USB_SUPPORT
MAINTAINER:=Nuno Goncalves <nunojpg@gmail.com>
endef
@ -38,19 +39,19 @@ endef
define Package/usbip
$(call Package/usbip/Default)
TITLE+= (common)
DEPENDS+= +glib2 +sysfsutils +libwrap +kmod-usbip
DEPENDS+= +libsysfs +libwrap +kmod-usbip
endef
define Package/usbip-client
$(call Package/usbip/Default)
TITLE+= (client)
DEPENDS+= usbip +kmod-usbip-client
DEPENDS+= usbip +glib2 +kmod-usbip-client
endef
define Package/usbip-server
$(call Package/usbip/Default)
TITLE+= (server)
DEPENDS+= usbip +kmod-usbip-server
DEPENDS+= usbip +glib2 +kmod-usbip-server
endef
define KernelPackage/usbip/Default
@ -76,7 +77,6 @@ endef
define KernelPackage/usbip-client
$(call KernelPackage/usbip/Default)
SUBMENU:=USB Support
TITLE+= (kernel client driver)
DEPENDS+= kmod-usbip
KCONFIG:= CONFIG_USB_IP_VHCI_HCD CONFIG_USBIP_VHCI_HCD
@ -86,7 +86,6 @@ endef
define KernelPackage/usbip-server
$(call KernelPackage/usbip/Default)
SUBMENU:=USB Support
TITLE+= (kernel host driver)
DEPENDS+= kmod-usbip
KCONFIG:= CONFIG_USB_IP_HOST CONFIG_USBIP_HOST
@ -107,11 +106,6 @@ LIBTOOL_PATHS:=./src
CFLAGS+="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include"
define Build/Prepare
$(call Build/Prepare/Default)
(cd $(PKG_BUILD_DIR)/src; autoreconf -v --install || exit 1 )
endef
define Build/Compile/kmod
$(MAKE) $(KERNEL_MAKEOPTS) \
SUBDIRS="$(LINUX_DIR)/drivers/staging/usbip" \
@ -134,10 +128,10 @@ define Package/usbip/install
$(CP) \
$(PKG_INSTALL_DIR)/usr/lib/libusbip.so.* \
$(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/share/hwdata
$(INSTALL_DIR) $(1)/usr/share/usbip
$(CP) \
$(PKG_INSTALL_DIR)/usr/share/usbip/usb.ids \
$(1)/usr/share/hwdata/
$(1)/usr/share/usbip/
endef
define Package/usbip-client/install

View File

@ -0,0 +1,11 @@
Index: trunk/src/cmd/Makefile.am
===================================================================
--- trunk/src/cmd/Makefile.am (revision 98)
+++ trunk/src/cmd/Makefile.am (revision 99)
@@ -17,5 +17,5 @@
INCLUDES = -I$(top_srcdir)/lib
LDADD = ../lib/libusbip.la @PACKAGE_LIBS@
EXTRA_CFLAGS = @EXTRA_CFLAGS@
-AM_CFLAGS = -Wall -W -Wstrict-prototypes -std=gnu99 $(EXTRA_CFLAGS) @PACKAGE_CFLAGS@
+AM_CFLAGS = -Wall -W -Wstrict-prototypes -std=gnu99 $(EXTRA_CFLAGS) @PACKAGE_CFLAGS@ -DUSBIDS_FILE='"@USBIDS_DIR@/usb.ids"'