fix cups compile on freebsd
git-svn-id: svn://svn.openwrt.org/openwrt/packages@5111 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
d0bafbabb1
commit
e201995543
@ -43,19 +43,21 @@ define Package/cups/conffiles
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default, --with-gnu-ld \
|
||||
--with-cups-user=root \
|
||||
--with-cups-group=root \
|
||||
--without-perl \
|
||||
--without-python \
|
||||
--without-php \
|
||||
--disable-slp \
|
||||
--disable-gnutls \
|
||||
--disable-openssl \
|
||||
--disable-cdsassl \
|
||||
--disable-ssl \
|
||||
--disable-slp \
|
||||
)
|
||||
$(call Build/Configure/Default, --with-gnu-ld \
|
||||
--with-cups-user=root \
|
||||
--with-cups-group=root \
|
||||
--without-perl \
|
||||
--without-python \
|
||||
--without-php \
|
||||
--enable-shared \
|
||||
--disable-slp \
|
||||
--disable-gnutls \
|
||||
--disable-openssl \
|
||||
--disable-cdsassl \
|
||||
--disable-ssl \
|
||||
--disable-slp, \
|
||||
UNAME="Linux" \
|
||||
)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
@ -65,6 +67,10 @@ define Build/Compile
|
||||
DSTROOT="$(PKG_INSTALL_DIR)" \
|
||||
STRIP="/bin/true" \
|
||||
all install
|
||||
if [ -d $(PKG_INSTALL_DIR)/usr/libexec ]; then \
|
||||
rm -rf $(PKG_INSTALL_DIR)/usr/lib; \
|
||||
mv $(PKG_INSTALL_DIR)/usr/libexec $(PKG_INSTALL_DIR)/usr/lib; \
|
||||
fi
|
||||
endef
|
||||
|
||||
define Package/cups/install
|
||||
@ -91,9 +97,6 @@ define Package/cups/install
|
||||
# install initscript with priority 60
|
||||
install -d -m0755 $(1)/etc/init.d
|
||||
install -m0755 ./files/cupsd.init $(1)/etc/init.d/S60cupsd
|
||||
find $(1) -name CVS | xargs rm -rf
|
||||
$(RSTRIP) $(1)
|
||||
$(IPKG_BUILD) $(1) $(PACKAGE_DIR)
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
|
11
net/cups/patches/130-no_chown.patch
Normal file
11
net/cups/patches/130-no_chown.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- cups-1.1.23/systemv/Makefile.old Sun Oct 15 03:33:34 2006
|
||||
+++ cups-1.1.23/systemv/Makefile Sun Oct 15 03:33:55 2006
|
||||
@@ -77,7 +77,7 @@
|
||||
$(INSTALL_BIN) lp $(BINDIR)
|
||||
$(INSTALL_BIN) lpoptions $(BINDIR)
|
||||
$(INSTALL_BIN) lpstat $(BINDIR)
|
||||
- -$(INSTALL_BIN) -m 4755 -o $(CUPS_USER) -g $(CUPS_GROUP) lppasswd $(BINDIR)
|
||||
+ -$(INSTALL_BIN) lppasswd $(BINDIR)
|
||||
if test ! -x $(BINDIR)/lppasswd; then \
|
||||
chmod 755 $(BINDIR)/lppasswd; \
|
||||
fi
|
11
net/cups/patches/140-uname.patch
Normal file
11
net/cups/patches/140-uname.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- cups.dev/configure Sun Oct 15 15:22:17 2006
|
||||
+++ cups.old/configure Sun Oct 15 15:21:40 2006
|
||||
@@ -1300,7 +1300,7 @@
|
||||
|
||||
|
||||
|
||||
-uname=`uname`
|
||||
+uname=${UNAME:-`uname`}
|
||||
uversion=`uname -r | sed -e '1,$s/[^0-9]//g'`
|
||||
case "$uname" in
|
||||
GNU* | GNU/*)
|
Loading…
x
Reference in New Issue
Block a user