horst: moved to github
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41937 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
abb5ae475e
commit
e336b437d6
@ -1,43 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=horst
|
||||
PKG_VERSION:=3.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://br1.einfach.org/horst_dl/
|
||||
PKG_MD5SUM:=076d836733fb6ce53a590eddf92ad358
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/horst
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
SUBMENU:=wireless
|
||||
DEPENDS:=+libncurses
|
||||
MAINTAINER:=Bruno Randolf <br1@einfach.org>
|
||||
TITLE:=Highly Optimized 802.11 Radio Scanning Tool
|
||||
URL:=http://br1.einfach.org/horst/
|
||||
endef
|
||||
|
||||
define Package/horst/description
|
||||
[horst] is a scanning and analysis tool for 802.11 wireless networks
|
||||
and especially IBSS (ad-hoc) mode and mesh networks (OLSR).
|
||||
endef
|
||||
|
||||
define Package/horst/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/horst $(1)/usr/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/horst.sh $(1)/usr/sbin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,horst))
|
@ -1,21 +0,0 @@
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -34,9 +34,7 @@ CFLAGS+=-DPCAP
|
||||
LIBS+=-lpcap
|
||||
endif
|
||||
|
||||
-buildstamp=.build_debug$(DEBUG)pcap$(PCAP)
|
||||
-
|
||||
-all: $(buildstamp) $(NAME)
|
||||
+all: $(NAME)
|
||||
|
||||
# include dependencies
|
||||
average.o: average.h util.h
|
||||
@@ -73,7 +71,3 @@ clean:
|
||||
-rm -f *.o *~
|
||||
-rm -f $(NAME)
|
||||
-rm -f .build_*
|
||||
-
|
||||
-$(buildstamp):
|
||||
- make clean
|
||||
- touch $@
|
Loading…
x
Reference in New Issue
Block a user