[packages] pciutils: Revert r19252's postinst changes, make $DEST a relative path

git-svn-id: svn://svn.openwrt.org/openwrt/packages@19255 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
swalker 2010-01-21 12:58:33 +00:00
parent b62ff83128
commit e44862284f
3 changed files with 16 additions and 3 deletions

View File

@ -34,7 +34,8 @@ endef
define Package/pciutils/postinst
#!/bin/sh
$${IPKG_INSTROOT}/usr/sbin/update-pciids
(cd $${IPKG_INSTROOT}/usr/share; $${IPKG_INSTROOT}/usr/sbin/update-pciids)
exit 0
endef
MAKE_FLAGS += \

View File

@ -11,15 +11,16 @@
# then just skip this whole process.
if ! touch ${DEST} >/dev/null 2>&1 ; then
${quiet} || echo "${DEST} is read-only, exiting." 1>&2
@@ -18,7 +17,6 @@ fi
@@ -18,7 +17,7 @@ fi
if [ -n "$PCI_COMPRESSED_IDS" ] ; then
DECOMP="cat"
SRC="$SRC.gz"
- GREP=zgrep
+ DEST="$DEST.gz"
elif which bzip2 >/dev/null 2>&1 ; then
DECOMP="bzip2 -d"
SRC="$SRC.bz2"
@@ -53,7 +51,7 @@ if ! $DECOMP <$DEST.new >$DEST.neww ; th
@@ -53,7 +52,7 @@ if ! $DECOMP <$DEST.new >$DEST.neww ; th
exit 1
fi

View File

@ -0,0 +1,11 @@
--- a/Makefile
+++ b/Makefile
@@ -78,7 +78,7 @@ setpci.o: setpci.c pciutils.h $(PCIINC)
common.o: common.c pciutils.h $(PCIINC)
update-pciids: update-pciids.sh
- sed <$< >$@ "s@^DEST=.*@DEST=$(IDSDIR)/$(PCI_IDS)@;s@^PCI_COMPRESSED_IDS=.*@PCI_COMPRESSED_IDS=$(PCI_COMPRESSED_IDS)@"
+ sed <$< >$@ "s@^PCI_COMPRESSED_IDS=.*@PCI_COMPRESSED_IDS=$(PCI_COMPRESSED_IDS)@"
chmod +x $@
# The example of use of libpci