[packages] update lirc to v0.8.4a and remove obsolete patches, thanks russell

git-svn-id: svn://svn.openwrt.org/openwrt/packages@14731 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2009-03-02 21:52:45 +00:00
parent f85f7dca2b
commit e886895e1e
3 changed files with 2 additions and 33 deletions

View File

@ -11,12 +11,12 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=lirc
PKG_VERSION:=0.8.3
PKG_VERSION:=0.8.4a
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/${PKG_NAME}
PKG_MD5SUM:=8e78eeded7b31e5ad02e328970437c0f
PKG_MD5SUM:=606b714ed843d28060163ffc571fc1f7
include $(INCLUDE_DIR)/package.mk

View File

@ -1,16 +0,0 @@
--- a/drivers/kcompat.h
+++ b/drivers/kcompat.h
@@ -53,7 +53,13 @@
#else /* >= 2.6.15 */
+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,25)
+#define lirc_class_device_create device_create_drvdata
+#define class_device_destroy device_destroy
+#else
#define lirc_class_device_create class_device_create
+#endif
+
#define LIRC_DEVFS_PREFIX
#endif

View File

@ -1,15 +0,0 @@
diff -urN lirc-0.8.3/drivers/lirc_dev/lirc_dev.c lirc-0.8.3.new/drivers/lirc_dev/lirc_dev.c
--- lirc-0.8.3/drivers/lirc_dev/lirc_dev.c 2008-01-13 11:45:02.000000000 +0100
+++ lirc-0.8.3.new/drivers/lirc_dev/lirc_dev.c 2009-01-13 00:23:56.000000000 +0100
@@ -49,7 +49,11 @@
#include <linux/uaccess.h>
#include <linux/errno.h>
#endif
+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,27)
#include <asm/semaphore.h>
+#else
+#include <linux/semaphore.h>
+#endif
#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 0)
#include <linux/wrapper.h>
#endif