[packages] add package 'seeks' - thanks to Obinou

git-svn-id: svn://svn.openwrt.org/openwrt/packages@27124 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
mirko 2011-06-07 10:24:57 +00:00
parent a30bb33997
commit eb86aca7d2
5 changed files with 240 additions and 0 deletions

114
net/seeks/Makefile Normal file
View File

@ -0,0 +1,114 @@
#
# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=seeks
PKG_VERSION:=0.3.4
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=git://seeks.git.sourceforge.net/gitroot/seeks/seeks
PKG_SOURCE_PROTO=git
PKG_SOURCE_VERSION:=e8565b98cfe40fba644f587536f15f1a8665d230
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
define Package/seeks
SUBMENU:=Web Servers/Proxies
SECTION:=net
CATEGORY:=Network
TITLE:=An open P2P design for websearch
URL:=http://www.seeks-project.info/site/
DEPENDS:=+libpthread +libevent +libcurl +libpcre +libxml2 $(ICONV_DEPENDS) +zlib +protobuf +tokyocabinet
MAINTAINER:=Obinou <obconseil@gmail.com>
endef
define Package/seeks/description
Seeks is a free and open P2P design and application for enabling social
websearch. Its specific purpose is to regroup users whose queries
are similar so they can share both the query results and their
experience on these results. On this basis, Seeks allows for true
real-time, decentralized, websearch to emerge.
In the long term, there is no need for web crawlers and third-party
web indexes as users can push content directly to search groups.
By hashing queries, Seeks offers a unique solution that allows to
issue queries and get answers while not revealing the true query itself.
Seeks is currently under development. Code is available from our git
repository. Help on any of the social, technical and software matters
is greatly encouraged and appreciated, see the dedicated page.
endef
CONFIGURE_VARS:= \
CXXFLAGS="-I$(STAGING_DIR)/usr/include $(ICONV_CFLAGS)" \
LDFLAGS="-L$(STAGING_DIR)/usr/lib $(ICONV_LDFLAGS)" \
CONFIGURE_ARGS += \
--prefix=/usr \
--enable-httpserv-plugin \
--enable-keepalive \
--disable-image-websearch-plugin \
--disable-icu
define Build/Configure
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
./autogen.sh \
);
$(call Build/Configure/Default)
endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
CXXFLAGS="-I$(STAGING_DIR)/usr/include $(ICONV_CFLAGS)"
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
install
endef
define Package/seeks/conffiles
/etc/config/seeks
/etc/seeks/config
endef
define Package/seeks/install
# Binary program
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/seeks $(1)/usr/bin/
# Config files
$(INSTALL_DIR) $(1)/etc/seeks
$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/seeks/* $(1)/etc/seeks/
# Libs
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib*.so* $(1)/usr/lib
$(INSTALL_DIR) $(1)/usr/lib/seeks/plugins/blocker
$(INSTALL_DIR) $(1)/usr/lib/seeks/plugins/httpserv
$(INSTALL_DIR) $(1)/usr/lib/seeks/plugins/websearch
$(INSTALL_DIR) $(1)/usr/lib/seeks/plugins/query_capture
$(INSTALL_DIR) $(1)/usr/lib/seeks/plugins/uri_capture
$(INSTALL_DIR) $(1)/usr/lib/seeks/plugins/cf
$(INSTALL_DIR) $(1)/usr/lib/seeks/plugins/udb_service
$(CP) $(PKG_INSTALL_DIR)/usr/lib/seeks/plugins/blocker/lib*.so* $(1)/usr/lib/seeks/plugins/blocker
$(CP) $(PKG_INSTALL_DIR)/usr/lib/seeks/plugins/httpserv/lib*.so* $(1)/usr/lib/seeks/plugins/httpserv
$(CP) $(PKG_INSTALL_DIR)/usr/lib/seeks/plugins/websearch/lib*.so* $(1)/usr/lib/seeks/plugins/websearch
$(CP) $(PKG_INSTALL_DIR)/usr/lib/seeks/plugins/query_capture/lib*.so* $(1)/usr/lib/seeks/plugins/query_capture
$(CP) $(PKG_INSTALL_DIR)/usr/lib/seeks/plugins/uri_capture/lib*.so* $(1)/usr/lib/seeks/plugins/uri_capture
$(CP) $(PKG_INSTALL_DIR)/usr/lib/seeks/plugins/cf/lib*.so* $(1)/usr/lib/seeks/plugins/cf
$(CP) $(PKG_INSTALL_DIR)/usr/lib/seeks/plugins/udb_service/lib*.so* $(1)/usr/lib/seeks/plugins/udb_service
#Share
$(INSTALL_DIR) $(1)/usr/share/seeks
$(CP) -r $(PKG_INSTALL_DIR)/usr/share/seeks/* $(1)/usr/share/seeks/
# This is OpenWRT specific config & scripts
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/seeks.init $(1)/etc/init.d/seeks
endef
$(eval $(call BuildPackage,seeks))

View File

@ -0,0 +1,21 @@
#!/bin/sh /etc/rc.common
# Copyright (C) 2008 OpenWrt.org
START=99
DAEMON=/usr/bin/seeks
start() {
echo 'seeks is starting...'
start-stop-daemon -S -q -x "$DAEMON" -- --daemon
}
stop() {
echo 'seeks is stopping...'
start-stop-daemon -K -q -x "$DAEMON"
}
restart() {
stop
sleep 2
start
}

View File

@ -0,0 +1,39 @@
diff -ru seeks-0.3.3/configure.in seeks-0.3.3-new/configure.in
--- seeks-0.3.3/configure.in 2011-04-30 10:16:57.000000000 +0200
+++ seeks-0.3.3-new/configure.in 2011-05-28 14:44:13.094516755 +0200
@@ -351,17 +351,25 @@
#==========================================================================
# Finding icu
#==========================================================================
-# First, check for the icu-config tool
-AC_PATH_PROGS(ICU_CONFIG, icu-config, no)
-if test x$ICU_CONFIG = xno; then
- AM_CONDITIONAL(HAVE_ICU,false)
+AC_ARG_ENABLE(icu,
+AC_HELP_STRING([--disable-icu], [Don't use icu to detect and convert non-UTF8 strings (default is NO)]),
+[enableval2=$enableval],
+[enableval2=yes])
+if test $enableval2 = yes; then
+ # First, check for the icu-config tool
+ AC_PATH_PROGS(ICU_CONFIG, icu-config, no)
+ if test x$ICU_CONFIG = xno; then
+ AM_CONDITIONAL(HAVE_ICU,false)
+ else
+ AC_DEFINE(FEATURE_ICU,1,"ICU library is there")
+ AM_CONDITIONAL(HAVE_ICU,true)
+ ICU_LDADD=`$ICU_CONFIG --ldflags`
+ AC_SUBST(ICU_LDADD)
+ ICU_CFLAGS=`$ICU_CONFIG --cppflags`
+ AC_SUBST(ICU_CFLAGS)
+ fi
else
- AC_DEFINE(FEATURE_ICU,1,"ICU library is there")
- AM_CONDITIONAL(HAVE_ICU,true)
- ICU_LDADD=`$ICU_CONFIG --ldflags`
- AC_SUBST(ICU_LDADD)
- ICU_CFLAGS=`$ICU_CONFIG --cppflags`
- AC_SUBST(ICU_CFLAGS)
+ AM_CONDITIONAL(HAVE_ICU,false)
fi
#ICU_LDADD=`$ICU_CONFIG --ldflags`

View File

@ -0,0 +1,34 @@
diff -ru seeks-0.3.3/src/Makefile.am seeks-0.3.3-new/src/Makefile.am
--- seeks-0.3.3/src/Makefile.am 2011-04-30 10:16:57.000000000 +0200
+++ seeks-0.3.3-new/src/Makefile.am 2011-05-27 10:56:09.648313435 +0200
@@ -57,12 +57,12 @@
LDADD += -lseeksuserdb -lseeksuserdbfix
endif
endif
-LDADD += -lpcre -lpcreposix -lseekslsh -lseeksdht -lrmd160 -lpthread -lz @CURL_LDADD@
+LDADD += -lpcre -lpcreposix -lseekslsh -lseeksdht -lrmd160 -lpthread -lz -liconv @CURL_LDADD@
if !HAVE_BSD
LDADD += -ldl
endif
-SUBDIRS=utils proxy lsh dht plugins proxy/tests lsh/tests .
+SUBDIRS=utils proxy lsh dht plugins .
configdir=$(sysconfdir)/seeks
dist_config_DATA=config \
diff -rU5 seeks-0.3.3/src/plugins/websearch/Makefile.am seeks-0.3.3-new/src/plugins/websearch/Makefile.am
--- seeks-0.3.3/src/plugins/websearch/Makefile.am 2011-04-30 10:16:57.000000000 +0200
+++ seeks-0.3.3-new/src/plugins/websearch/Makefile.am 2011-05-24 00:42:34.836033228 +0200
@@ -42,11 +42,11 @@
if USE_PERL
libseekswebsearchplugin_la_CXXFLAGS += `perl -MExtUtils::Embed -e ccopts`
endif
-SUBDIRS=. tests
+SUBDIRS=.
websearchconfigdir=$(sysconfdir)/seeks
dist_websearchconfig_DATA=websearch-config
nobase_dist_websearchplugindata_DATA= \

View File

@ -0,0 +1,32 @@
diff -rU5 seeks-0.3.3/src/plugins/blocker/Makefile.am seeks-0.3.3-new/src/plugins/blocker/Makefile.am
--- seeks-0.3.3/src/plugins/blocker/Makefile.am 2010-12-05 09:33:05.000000000 +0100
+++ seeks-0.3.3-new/src/plugins/blocker/Makefile.am 2011-05-24 01:13:09.994085964 +0200
@@ -4,11 +4,11 @@
blockerplugindatadir = $(datadir)/seeks/plugins/blocker
AM_CXXFLAGS=-Wall -g -pipe
AM_CPPFLAGS= -I${srcdir} -I${srcdir}/../../utils -I${srcdir}/../../proxy -I${srcdir}/../../lsh \
-DSEEKS_CONFIGDIR='"$(sysconfdir)/seeks/"' `pkg-config --cflags protobuf` `pkg-config --cflags tokyocabinet` \
- -I../../proxy
+ -I../../proxy @PCRE_CFLAGS@
ACLOCAL_AMFLAGS=-I m4
blockerpluginlib_LTLIBRARIES=libblockerplugin.la
libblockerplugin_la_SOURCES=blocker.cpp blocker.h
diff -rU5 seeks-0.3.3/src/plugins/httpserv/Makefile.am seeks-0.3.3-new/src/plugins/httpserv/Makefile.am
--- seeks-0.3.3/src/plugins/httpserv/Makefile.am 2011-02-18 15:44:02.000000000 +0100
+++ seeks-0.3.3-new/src/plugins/httpserv/Makefile.am 2011-05-24 01:27:13.413787987 +0200
@@ -4,11 +4,11 @@
httpservplugindatadir = $(datadir)/seeks/plugins/httpserv
AM_CPPFLAGS=-Wno-deprecated -Wall -g -pipe \
-I${srcdir} -I${srcdir}/../websearch -I${srcdir}/../../utils -I${srcdir}/../../lsh -I${srcdir}/../../proxy \
- -I${srcdir}/../../dht
+ -I${srcdir}/../../dht @PCRE_CFLAGS@
if HAVE_TC
if HAVE_PROTOBUF
AM_CPPFLAGS+=-I${srcdir}/../query_capture -I${srcdir}/../cf `pkg-config --cflags protobuf` `pkg-config --cflags tokyocabinet`