[packages] ez-ipupdate: fix for zoneedit, rebase patches - didn't apply cleanly anymore (#4845)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@15073 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
a7c88444ae
commit
f07ce0dda2
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
# Copyright (C) 2006-2009 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ez-ipupdate
|
||||
PKG_VERSION:=3.0.11b8
|
||||
PKG_RELEASE:=3
|
||||
PKG_RELEASE:=4
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
|
||||
PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/e/ez-ipupdate \
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -Naur ez-ipupdate-3.0.11b7/ez-ipupdate.c ez-ipupdate-3.0.11b7-sr1/ez-ipupdate.c
|
||||
--- ez-ipupdate-3.0.11b7/ez-ipupdate.c 2002-03-12 01:31:47.000000000 +0200
|
||||
+++ ez-ipupdate-3.0.11b7-sr1/ez-ipupdate.c 2006-10-08 17:51:40.000000000 +0200
|
||||
diff -ur ez-ipupdate-3.0.11b8.orig/ez-ipupdate.c ez-ipupdate-3.0.11b8/ez-ipupdate.c
|
||||
--- ez-ipupdate-3.0.11b8.orig/ez-ipupdate.c 2009-03-29 22:37:09.000000000 +0200
|
||||
+++ ez-ipupdate-3.0.11b8/ez-ipupdate.c 2009-03-29 22:37:20.000000000 +0200
|
||||
@@ -103,6 +103,11 @@
|
||||
#define HEIPV6TB_DEFAULT_PORT "80"
|
||||
#define HEIPV6TB_REQUEST "/index.cgi"
|
||||
@ -13,7 +13,7 @@ diff -Naur ez-ipupdate-3.0.11b7/ez-ipupdate.c ez-ipupdate-3.0.11b7-sr1/ez-ipupda
|
||||
#define DEFAULT_TIMEOUT 120
|
||||
#define DEFAULT_UPDATE_PERIOD 120
|
||||
#define DEFAULT_RESOLV_PERIOD 30
|
||||
@@ -341,6 +346,10 @@
|
||||
@@ -344,6 +349,10 @@
|
||||
int HEIPV6TB_check_info(void);
|
||||
static char *HEIPV6TB_fields_used[] = { "server", "user", NULL };
|
||||
|
||||
@ -24,7 +24,7 @@ diff -Naur ez-ipupdate-3.0.11b7/ez-ipupdate.c ez-ipupdate-3.0.11b7-sr1/ez-ipupda
|
||||
struct service_t services[] = {
|
||||
{ "NULL",
|
||||
{ "null", "NULL", 0, },
|
||||
@@ -514,6 +523,16 @@
|
||||
@@ -517,6 +526,16 @@
|
||||
HEIPV6TB_DEFAULT_PORT,
|
||||
HEIPV6TB_REQUEST
|
||||
},
|
||||
@ -41,7 +41,7 @@ diff -Naur ez-ipupdate-3.0.11b7/ez-ipupdate.c ez-ipupdate-3.0.11b7-sr1/ez-ipupda
|
||||
};
|
||||
|
||||
static struct service_t *service = NULL;
|
||||
@@ -4246,6 +4265,165 @@
|
||||
@@ -4251,6 +4270,165 @@
|
||||
return(UPDATERES_OK);
|
||||
}
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -Naur ez-ipupdate-3.0.11b8-patched/example-dnsexit.conf ez-ipupdate-3.0.11b8-dnsexit/example-dnsexit.conf
|
||||
--- ez-ipupdate-3.0.11b8-patched/example-dnsexit.conf 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ ez-ipupdate-3.0.11b8-dnsexit/example-dnsexit.conf 2005-12-23 01:34:51.000000000 +0000
|
||||
diff -Nur ez-ipupdate-3.0.11b8.orig/example-dnsexit.conf ez-ipupdate-3.0.11b8/example-dnsexit.conf
|
||||
--- ez-ipupdate-3.0.11b8.orig/example-dnsexit.conf 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ ez-ipupdate-3.0.11b8/example-dnsexit.conf 2009-03-29 22:40:07.000000000 +0200
|
||||
@@ -0,0 +1,20 @@
|
||||
+#!/usr/sbin/ez-ipupdate -c
|
||||
+#
|
||||
@ -22,12 +22,12 @@ diff -Naur ez-ipupdate-3.0.11b8-patched/example-dnsexit.conf ez-ipupdate-3.0.11b
|
||||
+# ready to have ez-ipupdate running in the background all the time. to stop it
|
||||
+# you can use "killall -QUIT ez-ipupdate" under linux.
|
||||
+#daemon
|
||||
diff -Naur ez-ipupdate-3.0.11b8-patched/ez-ipupdate.c ez-ipupdate-3.0.11b8-dnsexit/ez-ipupdate.c
|
||||
--- ez-ipupdate-3.0.11b8-patched/ez-ipupdate.c 2005-12-23 01:33:54.000000000 +0000
|
||||
+++ ez-ipupdate-3.0.11b8-dnsexit/ez-ipupdate.c 2005-12-23 02:51:19.000000000 +0000
|
||||
@@ -103,6 +103,10 @@
|
||||
#define HEIPV6TB_DEFAULT_PORT "80"
|
||||
#define HEIPV6TB_REQUEST "/index.cgi"
|
||||
diff -Nur ez-ipupdate-3.0.11b8.orig/ez-ipupdate.c ez-ipupdate-3.0.11b8/ez-ipupdate.c
|
||||
--- ez-ipupdate-3.0.11b8.orig/ez-ipupdate.c 2009-03-29 22:39:46.000000000 +0200
|
||||
+++ ez-ipupdate-3.0.11b8/ez-ipupdate.c 2009-03-29 22:40:07.000000000 +0200
|
||||
@@ -108,6 +108,10 @@
|
||||
#define EVERYDNS_REQUEST "/index.php"
|
||||
#define EVERYDNS_VERSION "0.1"
|
||||
|
||||
+#define DNSEXIT_DEFAULT_SERVER "www.dnsexit.com"
|
||||
+#define DNSEXIT_DEFAULT_PORT "80"
|
||||
@ -36,9 +36,9 @@ diff -Naur ez-ipupdate-3.0.11b8-patched/ez-ipupdate.c ez-ipupdate-3.0.11b8-dnsex
|
||||
#define DEFAULT_TIMEOUT 120
|
||||
#define DEFAULT_UPDATE_PERIOD 120
|
||||
#define DEFAULT_RESOLV_PERIOD 30
|
||||
@@ -344,6 +348,11 @@
|
||||
int HEIPV6TB_check_info(void);
|
||||
static char *HEIPV6TB_fields_used[] = { "server", "user", NULL };
|
||||
@@ -353,6 +357,11 @@
|
||||
int EVERYDNS_check_info(void);
|
||||
static char *EVERYDNS_fields_used[] = { "server", "user", "host", "address", NULL };
|
||||
|
||||
+int DNSEXIT_update_entry(void);
|
||||
+int DNSEXIT_check_info(void);
|
||||
@ -48,9 +48,9 @@ diff -Naur ez-ipupdate-3.0.11b8-patched/ez-ipupdate.c ez-ipupdate-3.0.11b8-dnsex
|
||||
struct service_t services[] = {
|
||||
{ "NULL",
|
||||
{ "null", "NULL", 0, },
|
||||
@@ -517,6 +526,16 @@
|
||||
HEIPV6TB_DEFAULT_PORT,
|
||||
HEIPV6TB_REQUEST
|
||||
@@ -536,6 +545,16 @@
|
||||
EVERYDNS_DEFAULT_PORT,
|
||||
EVERYDNS_REQUEST
|
||||
},
|
||||
+ { "dnsexit",
|
||||
+ { "dnsexit", 0, 0, },
|
||||
@ -65,7 +65,7 @@ diff -Naur ez-ipupdate-3.0.11b8-patched/ez-ipupdate.c ez-ipupdate-3.0.11b8-dnsex
|
||||
};
|
||||
|
||||
static struct service_t *service = NULL;
|
||||
@@ -4251,6 +4270,195 @@
|
||||
@@ -4429,6 +4448,195 @@
|
||||
return(UPDATERES_OK);
|
||||
}
|
||||
|
||||
|
12
net/ez-ipupdate/patches/004-zoneedit.patch
Normal file
12
net/ez-ipupdate/patches/004-zoneedit.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- ez-ipupdate-3.0.11b8.orig/ez-ipupdate.c
|
||||
+++ ez-ipupdate-3.0.11b8/ez-ipupdate.c
|
||||
@@ -95,7 +95,7 @@
|
||||
#define HN_DEFAULT_PORT "80"
|
||||
#define HN_REQUEST "/vanity/update"
|
||||
|
||||
-#define ZONEEDIT_DEFAULT_SERVER "www.zoneedit.com"
|
||||
+#define ZONEEDIT_DEFAULT_SERVER "dynamic.zoneedit.com"
|
||||
#define ZONEEDIT_DEFAULT_PORT "80"
|
||||
#define ZONEEDIT_REQUEST "/auth/dynamic.html"
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user