Update python to 2.5.4 (#4408)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@13824 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2009-01-02 15:06:42 +00:00
parent c1359fe6e2
commit f215a586b9
4 changed files with 60 additions and 2511 deletions

View File

@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python
PKG_VERSION:=2.5.1
PKG_RELEASE:=2
PKG_VERSION:=2.5.4
PKG_RELEASE:=1
PKG_SOURCE:=Python-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.python.org/ftp/python/$(PKG_VERSION)/
#PKG_MD5SUM:=afb5451049eda91fbde10bd5a4b7fadc
PKG_MD5SUM:=394a5f56a5ce811fb0f023197ec0833e
PKG_BUILD_DIR:=$(BUILD_DIR)/Python-$(PKG_VERSION)

View File

@ -30,10 +30,11 @@ Index: Python-2.5.1/Makefile.pre.in
esac
# Build static library
@@ -470,7 +471,7 @@
@@ -470,8 +471,8 @@
$(GRAMMAR_H) $(GRAMMAR_C): $(PGEN) $(GRAMMAR_INPUT)
-@ mkdir Include
- -$(PGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C)
+ -$(HOSTPGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C)

File diff suppressed because it is too large Load Diff

View File

@ -23,15 +23,13 @@ diff -urN Python-2.5.1.orig/Modules/signalmodule.c Python-2.5.1/Modules/signalmo
#ifndef SIG_ERR
#define SIG_ERR ((PyOS_sighandler_t)(-1))
#endif
@@ -75,6 +77,8 @@
@@ -75,4 +77,6 @@
PyObject *func;
} Handlers[NSIG];
+static int wakeup_fd = -1;
+
static int is_tripped = 0; /* Speed up sigcheck() when none tripped */
static PyObject *DefaultHandler;
/* Speed up sigcheck() when none tripped */
@@ -112,6 +116,7 @@
static void
signal_handler(int sig_num)