Update python to 2.5.4 (#4408)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@13824 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
c1359fe6e2
commit
f215a586b9
@ -9,12 +9,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=python
|
PKG_NAME:=python
|
||||||
PKG_VERSION:=2.5.1
|
PKG_VERSION:=2.5.4
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=Python-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=Python-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://www.python.org/ftp/python/$(PKG_VERSION)/
|
PKG_SOURCE_URL:=http://www.python.org/ftp/python/$(PKG_VERSION)/
|
||||||
#PKG_MD5SUM:=afb5451049eda91fbde10bd5a4b7fadc
|
PKG_MD5SUM:=394a5f56a5ce811fb0f023197ec0833e
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/Python-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/Python-$(PKG_VERSION)
|
||||||
|
|
||||||
|
@ -30,10 +30,11 @@ Index: Python-2.5.1/Makefile.pre.in
|
|||||||
esac
|
esac
|
||||||
|
|
||||||
# Build static library
|
# Build static library
|
||||||
@@ -470,7 +471,7 @@
|
@@ -470,8 +471,8 @@
|
||||||
|
|
||||||
|
|
||||||
$(GRAMMAR_H) $(GRAMMAR_C): $(PGEN) $(GRAMMAR_INPUT)
|
$(GRAMMAR_H) $(GRAMMAR_C): $(PGEN) $(GRAMMAR_INPUT)
|
||||||
|
-@ mkdir Include
|
||||||
- -$(PGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C)
|
- -$(PGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C)
|
||||||
+ -$(HOSTPGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C)
|
+ -$(HOSTPGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C)
|
||||||
|
|
||||||
|
File diff suppressed because it is too large
Load Diff
@ -23,15 +23,13 @@ diff -urN Python-2.5.1.orig/Modules/signalmodule.c Python-2.5.1/Modules/signalmo
|
|||||||
#ifndef SIG_ERR
|
#ifndef SIG_ERR
|
||||||
#define SIG_ERR ((PyOS_sighandler_t)(-1))
|
#define SIG_ERR ((PyOS_sighandler_t)(-1))
|
||||||
#endif
|
#endif
|
||||||
@@ -75,6 +77,8 @@
|
@@ -75,4 +77,6 @@
|
||||||
PyObject *func;
|
PyObject *func;
|
||||||
} Handlers[NSIG];
|
} Handlers[NSIG];
|
||||||
|
|
||||||
+static int wakeup_fd = -1;
|
+static int wakeup_fd = -1;
|
||||||
+
|
+
|
||||||
static int is_tripped = 0; /* Speed up sigcheck() when none tripped */
|
/* Speed up sigcheck() when none tripped */
|
||||||
|
|
||||||
static PyObject *DefaultHandler;
|
|
||||||
@@ -112,6 +116,7 @@
|
@@ -112,6 +116,7 @@
|
||||||
static void
|
static void
|
||||||
signal_handler(int sig_num)
|
signal_handler(int sig_num)
|
||||||
|
Loading…
x
Reference in New Issue
Block a user