Add xmail from #1309
git-svn-id: svn://svn.openwrt.org/openwrt/packages@7280 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
f3598d0938
commit
f4b3bb9664
58
net/xmail/Makefile
Normal file
58
net/xmail/Makefile
Normal file
@ -0,0 +1,58 @@
|
||||
#
|
||||
# Copyright (C) 2007 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id: $
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=xmail
|
||||
PKG_VERSION:=1.24
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_URL:=http://www.xmailserver.org/
|
||||
PKG_MD5SUM:=106730bdbaa4fda9e90a7c22df024114
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/xmail
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+uclibcxx +libopenssl
|
||||
TITLE:=advanced, fast and reliable ESMTP/POP3 mail server
|
||||
DESCRIPTION:=\
|
||||
XMail is an Internet mail server featuring an SMTP, POP3 and finger server. \\\
|
||||
It's incredibly easy to set up and has lots of features including : \\\
|
||||
multiple domains, virtual users and spam protection.
|
||||
URL:=http://www.xmailserver.org/
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(CP) ./files/SysMachine.h $(PKG_BUILD_DIR)/
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) -f Makefile.lnx \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
LDFLAGS="$(EXTRA_LDFLAGS) -luClibc++ -lssl -lm -lpthread -lcrypto -ldl" \
|
||||
WITH_SSL_INCLUDE="$(STAGING_DIR)/usr/include" \
|
||||
WITH_SSL_LIB="$(STAGING_DIR)/usr/lib" \
|
||||
CPPFLAGS="$(TARGET_CFLAGS)" \
|
||||
CXX="$(TARGET_CROSS)g++"
|
||||
endef
|
||||
|
||||
define Package/xmail/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/* $(1)/usr/bin/
|
||||
$(INSTALL_DIR) $(1)/var/MailRoot/
|
||||
$(CP) $(PKG_BUILD_DIR)/MailRoot $(1)/var/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,xmail))
|
24
net/xmail/files/SysMachine.h
Normal file
24
net/xmail/files/SysMachine.h
Normal file
@ -0,0 +1,24 @@
|
||||
#ifndef _MACHDEFS_H
|
||||
#define _MACHDEFS_H
|
||||
|
||||
|
||||
#undef MACH_BIG_ENDIAN_WORDS
|
||||
|
||||
#undef MACH_BIG_ENDIAN_BITFIELD
|
||||
|
||||
typedef signed char MachInt8;
|
||||
typedef unsigned char MachUInt8;
|
||||
#define MACH_TYPE_8BIT char
|
||||
|
||||
typedef signed short MachInt16;
|
||||
typedef unsigned short MachUInt16;
|
||||
#define MACH_TYPE_16BIT short
|
||||
|
||||
typedef signed int MachInt32;
|
||||
typedef unsigned int MachUInt32;
|
||||
#define MACH_TYPE_32BIT int
|
||||
|
||||
|
||||
|
||||
#endif
|
||||
|
21
net/xmail/patches/010-Makefile.common.patch
Normal file
21
net/xmail/patches/010-Makefile.common.patch
Normal file
@ -0,0 +1,21 @@
|
||||
--- xmail-1.24.orig/Makefile.common 2006-12-31 20:03:59.000000000 +0100
|
||||
+++ xmail-1.24/Makefile.common 2007-02-01 20:41:08.000000000 +0100
|
||||
@@ -76,15 +76,15 @@
|
||||
SENDMAILOBJS = SendMail.o
|
||||
|
||||
%.o : %.cpp
|
||||
- ${CC} ${CPPFLAGS} ${CFLAGS} -c $*.cpp
|
||||
+ ${CXX} ${CPPFLAGS} ${CFLAGS} -c $*.cpp
|
||||
|
||||
all: ${OUTDIR} ${MKMACHDEPINC} ${MAILSVR} ${CRTLCLNT} ${XMCRYPT} ${MKUSERS} ${SENDMAIL}
|
||||
|
||||
${OUTDIR}:
|
||||
@mkdir ${OUTDIR}
|
||||
|
||||
-${MKMACHDEPINC}: ${MKMACHDEP}
|
||||
- ./${MKMACHDEP} > ${MKMACHDEPINC}
|
||||
+#${MKMACHDEPINC}: ${MKMACHDEP}
|
||||
+# ./${MKMACHDEP} > ${MKMACHDEPINC}
|
||||
|
||||
${MKMACHDEP}: ${MKMACHDEPOBJS}
|
||||
${LD} -o ${MKMACHDEP} ${MKMACHDEPOBJS} ${LDFLAGS}
|
16
net/xmail/patches/020-Makefile.lnx.patch
Normal file
16
net/xmail/patches/020-Makefile.lnx.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff -ruaN xmail-1.24.orig/Makefile.lnx xmail-1.24/Makefile.lnx
|
||||
--- xmail-1.24.orig/Makefile.lnx 2006-12-31 20:03:59.000000000 +0100
|
||||
+++ xmail-1.24/Makefile.lnx 2007-02-02 13:11:29.000000000 +0100
|
||||
@@ -19,9 +19,9 @@
|
||||
# Davide Libenzi <davidel@xmailserver.org>
|
||||
#
|
||||
SYSTYPE = linux
|
||||
-CC = g++
|
||||
-LD = g++
|
||||
-STRIP = strip
|
||||
+CC = $(CXX)
|
||||
+LD = $(CXX)
|
||||
+#STRIP = strip
|
||||
|
||||
ifneq ("$(WITH_SSL_INCLUDE)", "")
|
||||
CFLAGS := $(CFLAGS) -I$(WITH_SSL_INCLUDE)
|
12
net/xmail/patches/030-xmail.patch
Normal file
12
net/xmail/patches/030-xmail.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -ruaN xmail-1.24.orig/xmail xmail-1.24/xmail
|
||||
--- xmail-1.24.orig/xmail 2006-12-31 20:03:59.000000000 +0100
|
||||
+++ xmail-1.24/xmail 2007-02-02 13:14:39.000000000 +0100
|
||||
@@ -19,7 +19,7 @@
|
||||
test -f $DAEMON || exit 0
|
||||
|
||||
set -e
|
||||
-ulimit -c 20000
|
||||
+ulimit -c 10000
|
||||
|
||||
start_xmail()
|
||||
{
|
Loading…
x
Reference in New Issue
Block a user