level up boost to version 0.46
- remove dedicated bjam-package since its maintaincene seems to only happen inside the boost tree now - remove not anymore required patches - add patch to remove hardcoded linker flags from jam file and move them into the OpenWrt Makefile (-pthreads -lrt) - remove package boost-function_types git-svn-id: svn://svn.openwrt.org/openwrt/packages@29189 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
5130b47998
commit
f84f8b88fd
@ -1,41 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=boost-jam
|
||||
PKG_VERSION:=3.1.17
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
||||
PKG_SOURCE_URL:=@SF/boost
|
||||
PKG_MD5SUM:=f4afd896788f2327fd35c128ddc6e340
|
||||
PKG_HOST_ONLY:=1
|
||||
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/boost-jam
|
||||
SECTION:=devel
|
||||
CATEGORY:=Development
|
||||
TITLE:=Boost JAM
|
||||
BUILDONLY:=1
|
||||
URL:=http://www.boost.org
|
||||
endef
|
||||
|
||||
define Host/Compile
|
||||
# bjam does not provide a configure-script nor a Makefile
|
||||
( cd $(HOST_BUILD_DIR) ; ./build.sh gcc )
|
||||
endef
|
||||
|
||||
define Host/Install
|
||||
$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
|
||||
$(CP) $(HOST_BUILD_DIR)/bin.*/bjam $(STAGING_DIR_HOST)/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call HostBuild))
|
||||
$(eval $(call BuildPackage,boost-jam))
|
@ -10,15 +10,16 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=boost
|
||||
PKG_VERSION:=1_38_0
|
||||
PKG_VERSION:=1_46_0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/boost
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_VERSION)
|
||||
PKG_MD5SUM:=a4fc691c4e7c49b3b9b54a667d8f5529
|
||||
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)_$(PKG_VERSION)
|
||||
PKG_MD5SUM:=820393d5746553c192db7b81ba0e53fe
|
||||
|
||||
PKG_BUILD_DEPENDS:=boost-jam/host
|
||||
PKG_BUILD_DEPENDS:=boost/host
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
PKG_CONFIG_DEPENDS := \
|
||||
@ -38,6 +39,7 @@ PKG_CONFIG_DEPENDS := \
|
||||
CONFIG_PACKAGE_boost-wave \
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
|
||||
define Package/boost/Default
|
||||
SECTION:=libs
|
||||
@ -61,12 +63,6 @@ define Package/boost-filesystem
|
||||
TITLE+= (filesystem)
|
||||
endef
|
||||
|
||||
define Package/boost-function_types
|
||||
$(call Package/boost/Default)
|
||||
TITLE+= (function_types)
|
||||
BUILD_ONLY:=1
|
||||
endef
|
||||
|
||||
define Package/boost-graph
|
||||
$(call Package/boost/Default)
|
||||
TITLE+= (graph)
|
||||
@ -143,7 +139,14 @@ endef
|
||||
define Build/Configure
|
||||
endef
|
||||
|
||||
define Host/Compile
|
||||
# bjam does not provide a configure-script nor a Makefile
|
||||
( cd $(HOST_BUILD_DIR)/tools/build/v2/engine/src ; ./build.sh gcc )
|
||||
endef
|
||||
|
||||
CONFIGURE_PREFIX:=$(PKG_INSTALL_DIR)
|
||||
TARGET_LDFLAGS += -pthreads -lrt
|
||||
|
||||
define Build/Compile
|
||||
( cd $(PKG_BUILD_DIR) ; \
|
||||
echo "using gcc : : $(GNU_TARGET_NAME)-gcc : <cflags>$(TARGET_CFLAGS) <cxxflags>$(TARGET_CXXFLAGS) <linkflags>$(TARGET_LDFLAGS) ;" > tools/build/v2/site-config.jam ; \
|
||||
@ -159,7 +162,6 @@ define Build/Compile
|
||||
$(CONFIGURE_ARGS) \
|
||||
$(if $(CONFIG_PACKAGE_boost-date_time),--with-date_time) \
|
||||
$(if $(CONFIG_PACKAGE_boost-filesystem),--with-filesystem) \
|
||||
$(if $(CONFIG_PACKAGE_boost-function_types),--with-function_types) \
|
||||
$(if $(CONFIG_PACKAGE_boost-graph),--with-graph) \
|
||||
$(if $(CONFIG_PACKAGE_boost-iostreams),--with-iostreams) \
|
||||
$(if $(CONFIG_PACKAGE_boost-math),--with-math) \
|
||||
@ -191,6 +193,11 @@ define Build/InstallDev
|
||||
fi
|
||||
endef
|
||||
|
||||
define Host/Install
|
||||
$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
|
||||
$(CP) $(HOST_BUILD_DIR)/tools/build/v2/engine/src/bin.*/bjam $(STAGING_DIR_HOST)/bin/
|
||||
endef
|
||||
|
||||
define Package/boost/Default/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/lib/libboost_$(2)*.so* $(1)/usr/lib/
|
||||
@ -258,10 +265,10 @@ define Package/boost-wave/install
|
||||
$(call Package/boost/Default/install,$(1),wave)
|
||||
endef
|
||||
|
||||
$(eval $(call HostBuild))
|
||||
$(eval $(call BuildPackage,boost))
|
||||
$(eval $(call BuildPackage,boost-date_time))
|
||||
$(eval $(call BuildPackage,boost-filesystem))
|
||||
$(eval $(call BuildPackage,boost-function_types))
|
||||
$(eval $(call BuildPackage,boost-graph))
|
||||
$(eval $(call BuildPackage,boost-iostreams))
|
||||
$(eval $(call BuildPackage,boost-math))
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -Naur boost_1_35_0.orig/libs/thread/src/pthread/thread.cpp boost_1_35_0/libs/thread/src/pthread/thread.cpp
|
||||
--- boost_1_35_0.orig/libs/thread/src/pthread/thread.cpp 2008-05-08 06:18:57.000000000 -0400
|
||||
+++ boost_1_35_0/libs/thread/src/pthread/thread.cpp 2008-05-08 06:20:15.000000000 -0400
|
||||
@@ -419,7 +419,7 @@
|
||||
#if defined(PTW32_VERSION) || defined(__hpux)
|
||||
return pthread_num_processors_np();
|
||||
#elif defined(__linux__)
|
||||
- return get_nprocs();
|
||||
+ return 1;
|
||||
#elif defined(__APPLE__) || defined(__FreeBSD__)
|
||||
int count;
|
||||
size_t size=sizeof(count);
|
@ -1,11 +0,0 @@
|
||||
--- boost_1_38_0/boost/python/detail/config.hpp 2007-11-25 19:07:19.000000000 +0100
|
||||
+++ boost_1_38_0/boost/python/detail/config.hpp 2010-02-26 02:06:26.000000000 +0100
|
||||
@@ -111,7 +111,7 @@
|
||||
# define BOOST_PYTHON_OFFSETOF(s_name, s_member) \
|
||||
((size_t)__INTADDR__(&(((s_name *)0)->s_member)))
|
||||
#else
|
||||
-# define BOOST_PYTHON_OFFSETOF offsetof
|
||||
+# define BOOST_PYTHON_OFFSETOF __builtin_offsetof
|
||||
#endif
|
||||
|
||||
// enable automatic library variant selection ------------------------------//
|
27
libs/boost/patches/100-do-not-use-librt.patch
Normal file
27
libs/boost/patches/100-do-not-use-librt.patch
Normal file
@ -0,0 +1,27 @@
|
||||
diff -ruN boost_1_48_0.orig/tools/build/v2/tools/gcc.jam boost_1_48_0/tools/build/v2/tools/gcc.jam
|
||||
--- boost_1_48_0.orig/tools/build/v2/tools/gcc.jam 2011-06-06 22:36:21.000000000 +0200
|
||||
+++ boost_1_48_0/tools/build/v2/tools/gcc.jam 2011-11-16 13:15:49.071254804 +0100
|
||||
@@ -1063,8 +1063,7 @@
|
||||
}
|
||||
case * :
|
||||
{
|
||||
- option = -pthread ;
|
||||
- libs = rt ;
|
||||
+ # pass appropriate options via OpenWrt
|
||||
}
|
||||
}
|
||||
|
||||
diff -ruN boost_1_48_0.orig/tools/build/v2/tools/gcc.py boost_1_48_0/tools/build/v2/tools/gcc.py
|
||||
--- boost_1_48_0.orig/tools/build/v2/tools/gcc.py 2011-01-25 19:06:12.000000000 +0100
|
||||
+++ boost_1_48_0/tools/build/v2/tools/gcc.py 2011-11-16 13:16:12.601254423 +0100
|
||||
@@ -685,8 +685,8 @@
|
||||
# Darwin has no threading options, don't set anything here.
|
||||
pass
|
||||
else:
|
||||
- flags('gcc', 'OPTIONS', ['<threading>multi'], ['-pthread'])
|
||||
- flags('gcc', 'FINDLIBS-SA', [], ['rt'])
|
||||
+ # pass appropriate options via OpenWrt
|
||||
+ pass
|
||||
|
||||
def cpu_flags(toolset, variable, architecture, instruction_set, values, default=None):
|
||||
#FIXME: for some reason this fails. Probably out of date feature code
|
Loading…
x
Reference in New Issue
Block a user