elfutils: update to 0.155
Based on patch from Vadim A. Misbakh-Soloviov <mva@mva.name> Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@35311 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
fca60ba7ca
commit
f86e014492
@ -7,12 +7,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=elfutils
|
||||
PKG_VERSION:=0.152
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=0.155
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://fedorahosted.org/releases/e/l/$(PKG_NAME)/$(PKG_VERSION)
|
||||
PKG_MD5SUM:=39739ed58a0fa1862eff8735f111fe5c
|
||||
PKG_MD5SUM:=163a5712b86f6bdfebdf233cc6e2192d
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
||||
@ -47,6 +47,9 @@ CONFIGURE_VARS += \
|
||||
LIBS="-largp"
|
||||
endif
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--disable-werror
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,99 +0,0 @@
|
||||
--- a/src/Makefile.in
|
||||
+++ b/src/Makefile.in
|
||||
@@ -322,7 +322,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
|
||||
-I$(srcdir)/../libdw -I$(srcdir)/../libdwfl \
|
||||
-I$(srcdir)/../libasm
|
||||
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
|
||||
- $($(*F)_no_Werror),,-Werror) $(if \
|
||||
+ $($(*F)_no_Werror),,) $(if \
|
||||
$($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
|
||||
$($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
|
||||
$(am__append_1)
|
||||
--- a/libelf/Makefile.in
|
||||
+++ b/libelf/Makefile.in
|
||||
@@ -280,7 +280,7 @@ top_srcdir = @top_srcdir@
|
||||
zip_LIBS = @zip_LIBS@
|
||||
INCLUDES = -I. -I$(srcdir) -I$(top_srcdir)/lib -I..
|
||||
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
|
||||
- $($(*F)_no_Werror),,-Werror) $(if \
|
||||
+ $($(*F)_no_Werror),,) $(if \
|
||||
$($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
|
||||
$($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
|
||||
$(am__append_1) $(am__append_2)
|
||||
--- a/lib/Makefile.in
|
||||
+++ b/lib/Makefile.in
|
||||
@@ -191,7 +191,7 @@ zip_LIBS = @zip_LIBS@
|
||||
INCLUDES = -I. -I$(srcdir) -I$(top_srcdir)/lib -I.. \
|
||||
-I$(srcdir)/../libelf
|
||||
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
|
||||
- $($(*F)_no_Werror),,-Werror) $(if \
|
||||
+ $($(*F)_no_Werror),,) $(if \
|
||||
$($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
|
||||
$($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
|
||||
$(am__append_1) -fpic
|
||||
--- a/libasm/Makefile.in
|
||||
+++ b/libasm/Makefile.in
|
||||
@@ -240,7 +240,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
|
||||
-I$(top_srcdir)/libelf -I$(top_srcdir)/libebl \
|
||||
-I$(top_srcdir)/libdw
|
||||
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
|
||||
- $($(*F)_no_Werror),,-Werror) $(if \
|
||||
+ $($(*F)_no_Werror),,) $(if \
|
||||
$($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
|
||||
$($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
|
||||
$(am__append_1)
|
||||
--- a/libcpu/Makefile.in
|
||||
+++ b/libcpu/Makefile.in
|
||||
@@ -209,7 +209,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
|
||||
-I$(srcdir)/../libelf -I$(srcdir)/../libebl \
|
||||
-I$(srcdir)/../libdw -I$(srcdir)/../libasm
|
||||
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
|
||||
- $($(*F)_no_Werror),,-Werror) $(if \
|
||||
+ $($(*F)_no_Werror),,) $(if \
|
||||
$($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
|
||||
$($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
|
||||
$(am__append_1) -fpic -fdollars-in-identifiers
|
||||
--- a/libdw/Makefile.in
|
||||
+++ b/libdw/Makefile.in
|
||||
@@ -284,7 +284,7 @@ zip_LIBS = @zip_LIBS@
|
||||
INCLUDES = -I. -I$(srcdir) -I$(top_srcdir)/lib -I.. \
|
||||
-I$(srcdir)/../libelf
|
||||
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
|
||||
- $($(*F)_no_Werror),,-Werror) $(if \
|
||||
+ $($(*F)_no_Werror),,) $(if \
|
||||
$($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
|
||||
$($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
|
||||
$(am__append_1) $(am__append_2)
|
||||
--- a/libdwfl/Makefile.in
|
||||
+++ b/libdwfl/Makefile.in
|
||||
@@ -275,7 +275,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
|
||||
-I$(srcdir)/../libelf -I$(srcdir)/../libebl \
|
||||
-I$(srcdir)/../libdw
|
||||
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
|
||||
- $($(*F)_no_Werror),,-Werror) $(if \
|
||||
+ $($(*F)_no_Werror),,) $(if \
|
||||
$($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
|
||||
$($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
|
||||
$(am__append_1)
|
||||
--- a/libebl/Makefile.in
|
||||
+++ b/libebl/Makefile.in
|
||||
@@ -236,7 +236,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
|
||||
-I$(srcdir)/../libelf -I$(srcdir)/../libdw \
|
||||
-I$(srcdir)/../libasm
|
||||
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
|
||||
- $($(*F)_no_Werror),,-Werror) $(if \
|
||||
+ $($(*F)_no_Werror),,) $(if \
|
||||
$($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
|
||||
$($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
|
||||
$(am__append_1) -fpic
|
||||
--- a/tests/Makefile.in
|
||||
+++ b/tests/Makefile.in
|
||||
@@ -463,7 +463,7 @@ top_srcdir = @top_srcdir@
|
||||
zip_LIBS = @zip_LIBS@
|
||||
INCLUDES = -I. -I$(srcdir) -I$(top_srcdir)/lib -I.. $(am__append_2)
|
||||
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
|
||||
- $($(*F)_no_Werror),,-Werror) $(if \
|
||||
+ $($(*F)_no_Werror),,) $(if \
|
||||
$($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
|
||||
$($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
|
||||
$(am__append_1)
|
@ -1,6 +1,6 @@
|
||||
--- a/libelf/libelf.h
|
||||
+++ b/libelf/libelf.h
|
||||
@@ -55,6 +55,11 @@
|
||||
@@ -34,6 +34,11 @@
|
||||
/* Get the ELF types. */
|
||||
#include <elf.h>
|
||||
|
||||
|
@ -1,19 +1,18 @@
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -30,8 +30,8 @@ ACLOCAL_AMFLAGS = -I m4
|
||||
@@ -23,8 +23,7 @@ ACLOCAL_AMFLAGS = -I m4
|
||||
pkginclude_HEADERS = version.h
|
||||
|
||||
# Add doc back when we have some real content.
|
||||
-SUBDIRS = config m4 lib libelf libebl libdwfl libdw libcpu libasm backends \
|
||||
- src po
|
||||
+SUBDIRS = config m4 lib libelf libebl libdwfl libdw
|
||||
+
|
||||
|
||||
EXTRA_DIST = elfutils.spec GPG-KEY NOTES EXCEPTION
|
||||
|
||||
EXTRA_DIST = elfutils.spec GPG-KEY NOTES CONTRIBUTING \
|
||||
COPYING COPYING-GPLV2 COPYING-LGPLV3
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -248,8 +248,7 @@ ACLOCAL_AMFLAGS = -I m4
|
||||
@@ -258,8 +258,7 @@ ACLOCAL_AMFLAGS = -I m4
|
||||
pkginclude_HEADERS = version.h
|
||||
|
||||
# Add doc back when we have some real content.
|
||||
@ -21,5 +20,5 @@
|
||||
- src po
|
||||
+SUBDIRS = config m4 lib libelf libebl libdwfl libdw
|
||||
|
||||
EXTRA_DIST = elfutils.spec GPG-KEY NOTES EXCEPTION
|
||||
|
||||
EXTRA_DIST = elfutils.spec GPG-KEY NOTES CONTRIBUTING \
|
||||
COPYING COPYING-GPLV2 COPYING-LGPLV3
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/libdw/Makefile.am
|
||||
+++ b/libdw/Makefile.am
|
||||
@@ -108,7 +108,7 @@ libdw.so: $(srcdir)/libdw.map libdw_pic.
|
||||
@@ -111,7 +111,7 @@ libdw.so: $(srcdir)/libdw.map libdw_pic.
|
||||
-Wl,--enable-new-dtags,-rpath,$(pkglibdir) \
|
||||
-Wl,--version-script,$<,--no-undefined \
|
||||
-Wl,--whole-archive $(filter-out $<,$^) -Wl,--no-whole-archive\
|
||||
@ -11,7 +11,7 @@
|
||||
|
||||
--- a/libdw/Makefile.in
|
||||
+++ b/libdw/Makefile.in
|
||||
@@ -839,7 +839,7 @@ uninstall-am: uninstall-includeHEADERS u
|
||||
@@ -845,7 +845,7 @@ uninstall-am: uninstall-includeHEADERS u
|
||||
@MUDFLAP_FALSE@ -Wl,--enable-new-dtags,-rpath,$(pkglibdir) \
|
||||
@MUDFLAP_FALSE@ -Wl,--version-script,$<,--no-undefined \
|
||||
@MUDFLAP_FALSE@ -Wl,--whole-archive $(filter-out $<,$^) -Wl,--no-whole-archive\
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/libasm/Makefile.am
|
||||
+++ b/libasm/Makefile.am
|
||||
@@ -66,7 +66,6 @@ libasm.so: libasm_pic.a libasm.map
|
||||
@@ -69,7 +69,6 @@ libasm.so: libasm_pic.a libasm.map
|
||||
-Wl,--version-script,$(srcdir)/libasm.map,--no-undefined \
|
||||
-Wl,--soname,$@.$(VERSION) \
|
||||
../libebl/libebl.a ../libelf/libelf.so $(libasm_so_LDLIBS)
|
||||
@ -10,7 +10,7 @@
|
||||
install: install-am libasm.so
|
||||
--- a/libasm/Makefile.in
|
||||
+++ b/libasm/Makefile.in
|
||||
@@ -648,7 +648,6 @@ uninstall-am: uninstall-libLIBRARIES uni
|
||||
@@ -656,7 +656,6 @@ uninstall-am: uninstall-libLIBRARIES uni
|
||||
@MUDFLAP_FALSE@ -Wl,--version-script,$(srcdir)/libasm.map,--no-undefined \
|
||||
@MUDFLAP_FALSE@ -Wl,--soname,$@.$(VERSION) \
|
||||
@MUDFLAP_FALSE@ ../libebl/libebl.a ../libelf/libelf.so $(libasm_so_LDLIBS)
|
||||
@ -20,7 +20,7 @@
|
||||
@MUDFLAP_FALSE@install: install-am libasm.so
|
||||
--- a/libdw/Makefile.am
|
||||
+++ b/libdw/Makefile.am
|
||||
@@ -109,7 +109,6 @@ libdw.so: $(srcdir)/libdw.map libdw_pic.
|
||||
@@ -112,7 +112,6 @@ libdw.so: $(srcdir)/libdw.map libdw_pic.
|
||||
-Wl,--version-script,$<,--no-undefined \
|
||||
-Wl,--whole-archive $(filter-out $<,$^) -Wl,--no-whole-archive\
|
||||
-ldl $(zip_LIBS) $(LIBS)
|
||||
@ -30,7 +30,7 @@
|
||||
install: install-am libdw.so
|
||||
--- a/libdw/Makefile.in
|
||||
+++ b/libdw/Makefile.in
|
||||
@@ -840,7 +840,6 @@ uninstall-am: uninstall-includeHEADERS u
|
||||
@@ -846,7 +846,6 @@ uninstall-am: uninstall-includeHEADERS u
|
||||
@MUDFLAP_FALSE@ -Wl,--version-script,$<,--no-undefined \
|
||||
@MUDFLAP_FALSE@ -Wl,--whole-archive $(filter-out $<,$^) -Wl,--no-whole-archive\
|
||||
@MUDFLAP_FALSE@ -ldl $(zip_LIBS) $(LIBS)
|
||||
@ -40,7 +40,7 @@
|
||||
@MUDFLAP_FALSE@install: install-am libdw.so
|
||||
--- a/libelf/Makefile.am
|
||||
+++ b/libelf/Makefile.am
|
||||
@@ -103,7 +103,6 @@ libelf.so: libelf_pic.a libelf.map
|
||||
@@ -106,7 +106,6 @@ libelf.so: libelf_pic.a libelf.map
|
||||
$(LINK) -shared -o $@ -Wl,--whole-archive,$<,--no-whole-archive \
|
||||
-Wl,--version-script,$(srcdir)/libelf.map,--no-undefined \
|
||||
-Wl,--soname,$@.$(VERSION),-z,defs,-z,relro $(libelf_so_LDLIBS)
|
||||
@ -50,7 +50,7 @@
|
||||
install: install-am libelf.so
|
||||
--- a/libelf/Makefile.in
|
||||
+++ b/libelf/Makefile.in
|
||||
@@ -826,7 +826,6 @@ uninstall-am: uninstall-includeHEADERS u
|
||||
@@ -832,7 +832,6 @@ uninstall-am: uninstall-includeHEADERS u
|
||||
@MUDFLAP_FALSE@ $(LINK) -shared -o $@ -Wl,--whole-archive,$<,--no-whole-archive \
|
||||
@MUDFLAP_FALSE@ -Wl,--version-script,$(srcdir)/libelf.map,--no-undefined \
|
||||
@MUDFLAP_FALSE@ -Wl,--soname,$@.$(VERSION),-z,defs,-z,relro $(libelf_so_LDLIBS)
|
||||
|
Loading…
x
Reference in New Issue
Block a user