spandsp: moved to telephony feed
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41738 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
e6ec0fbd34
commit
f88372f6aa
@ -1,46 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2010-2012 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=spandsp
|
||||
PKG_VERSION:=0.0.6
|
||||
PKG_VERSION_SUFFIX:=pre17
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)$(PKG_VERSION_SUFFIX).tgz
|
||||
PKG_SOURCE_URL:=http://www.soft-switch.org/downloads/spandsp/
|
||||
PKG_MD5SUM:=cc860f77270cf3b881f8ccd42d2d0238
|
||||
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_FIXUP:=autoreconf
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libspandsp
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=spandsp library
|
||||
DEPENDS:=+libtiff
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/{lib,include}
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libspandsp* $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
|
||||
endef
|
||||
|
||||
define Package/libspandsp/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libspandsp*so* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libspandsp))
|
@ -1,23 +0,0 @@
|
||||
--- a/src/spandsp/fast_convert.h
|
||||
+++ b/src/spandsp/fast_convert.h
|
||||
@@ -197,7 +197,7 @@ extern "C"
|
||||
{
|
||||
return (long int) (x);
|
||||
}
|
||||
-#elif defined(__ppc__) || defined(__powerpc__)
|
||||
+#elif defined(THISISNOTDEFINEDYADDAYADDA)
|
||||
static __inline__ long int lfastrint(register double x)
|
||||
{
|
||||
int res[2];
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -152,9 +152,7 @@ AC_ARG_ENABLE(builtin_tiff,
|
||||
|
||||
AC_FUNC_ERROR_AT_LINE
|
||||
AC_FUNC_VPRINTF
|
||||
-AC_FUNC_MALLOC
|
||||
AC_FUNC_MEMCMP
|
||||
-AC_FUNC_REALLOC
|
||||
AC_FUNC_SELECT_ARGTYPES
|
||||
|
||||
AX_C99_FUNC_LRINT
|
Loading…
x
Reference in New Issue
Block a user