[package] add e169-stats (#7101)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@20805 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
fb55c126e2
commit
fa5c575e7e
37
net/e169-stats/Makefile
Normal file
37
net/e169-stats/Makefile
Normal file
@ -0,0 +1,37 @@
|
||||
#
|
||||
# Copyright (C) 2010 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=e169-stats
|
||||
PKG_VERSION:=0.4
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.mavetju.org/download/
|
||||
PKG_MD5SUM:=11aa0b9abf6ff430ba90bbd7ee178774
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/e169-stats
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=e169-stats
|
||||
URL:=http://www.mavetju.org/weblog/html/00282.html
|
||||
DEPENDS:=+libncurses
|
||||
endef
|
||||
|
||||
define Package/e169-stats/description
|
||||
Huawei E169 statistics, works with other Huawei's devices.
|
||||
endef
|
||||
|
||||
define Package/e169-stats/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/e169-stats $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,e169-stats))
|
11
net/e169-stats/patches/01-make.patch
Normal file
11
net/e169-stats/patches/01-make.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- e169/Makefile.orig 2009-06-23 09:39:38.000000000 +0200
|
||||
+++ e169/Makefile 2010-04-05 22:57:56.000000000 +0200
|
||||
@@ -1,7 +1,7 @@
|
||||
all: e169-stats
|
||||
|
||||
e169-stats: e169-stats.c
|
||||
- gcc -Wall -o e169-stats e169-stats.c -lcurses
|
||||
+ $(CC) -Wall -o e169-stats e169-stats.c -lcurses -I$(STAGING_DIR)/usr/include -L$(STAGING_DIR)/usr/lib
|
||||
|
||||
clean:
|
||||
-rm e169-stats *.core
|
Loading…
x
Reference in New Issue
Block a user