[packages] rssh: update to 2.3.3, add missing DESTDIR for rssh_chroot_helper, fix conf perms, add /etc/shells postinst and cleanup Makefile
git-svn-id: svn://svn.openwrt.org/openwrt/packages@24661 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
b45978cef3
commit
fc6ef15bb7
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2007 OpenWrt.org
|
# Copyright (C) 2007-2010 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -8,12 +8,14 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=rssh
|
PKG_NAME:=rssh
|
||||||
PKG_VERSION:=2.3.2
|
PKG_VERSION:=2.3.3
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=@SF/rssh
|
PKG_SOURCE_URL:=@SF/rssh
|
||||||
PKG_MD5SUM:=65712f2c06ff5fc6fc783bc8c2e4e1ba
|
PKG_MD5SUM:=b0c147602fcc95737ed50573b92fc468
|
||||||
|
|
||||||
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
@ -35,28 +37,25 @@ define Package/rssh/conffiles
|
|||||||
/etc/rssh.conf
|
/etc/rssh.conf
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Configure
|
CONFIGURE_ARGS += \
|
||||||
$(call Build/Configure/Default,\
|
--with-sftp-server="/usr/libexec/sftp-server" \
|
||||||
--with-sftp-server="/usr/libexec/sftp-server" \
|
|
||||||
,\
|
|
||||||
ac_cv_func_malloc_0_nonnull=yes \
|
|
||||||
)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/Compile
|
CONFIGURE_VARS += \
|
||||||
$(call Build/Compile/Default,\
|
ac_cv_func_malloc_0_nonnull=yes \
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
|
||||||
all \
|
|
||||||
)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/rssh/install
|
define Package/rssh/install
|
||||||
$(INSTALL_DIR) $(1)/etc/
|
$(INSTALL_DIR) $(1)/etc
|
||||||
$(INSTALL_CONF) $(PKG_BUILD_DIR)/$(PKG_NAME).conf $(1)/etc/
|
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/$(PKG_NAME).conf $(1)/etc/
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
|
||||||
$(INSTALL_DIR) $(1)/usr/lib/
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/rssh_chroot_helper $(1)/usr/lib/
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/rssh_chroot_helper $(1)/usr/lib/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/rssh/postinst
|
||||||
|
#!/bin/sh
|
||||||
|
grep rssh $${IPKG_INSTROOT}/etc/shells || \
|
||||||
|
echo "/usr/bin/rssh" >> $${IPKG_INSTROOT}/etc/shells
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,rssh))
|
$(eval $(call BuildPackage,rssh))
|
||||||
|
22
net/rssh/patches/001-destdir.patch
Normal file
22
net/rssh/patches/001-destdir.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
--- a/Makefile.am
|
||||||
|
+++ b/Makefile.am
|
||||||
|
@@ -16,7 +16,7 @@ base=`echo @PACKAGE_STRING@|tr " " "-"`
|
||||||
|
$(CC) -c $(DEFS) $(ourdefs) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $<
|
||||||
|
|
||||||
|
install-exec-hook:
|
||||||
|
- chmod u+s $(libexecdir)/rssh_chroot_helper
|
||||||
|
+ chmod u+s $(DESTDIR)$(libexecdir)/rssh_chroot_helper
|
||||||
|
|
||||||
|
rpm: dist
|
||||||
|
rpmbuild -ta --sign $(base).tar.gz
|
||||||
|
--- a/Makefile.in
|
||||||
|
+++ b/Makefile.in
|
||||||
|
@@ -830,7 +830,7 @@ uninstall-man: uninstall-man1 uninstall-
|
||||||
|
$(CC) -c $(DEFS) $(ourdefs) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $<
|
||||||
|
|
||||||
|
install-exec-hook:
|
||||||
|
- chmod u+s $(libexecdir)/rssh_chroot_helper
|
||||||
|
+ chmod u+s $(DESTDIR)$(libexecdir)/rssh_chroot_helper
|
||||||
|
|
||||||
|
rpm: dist
|
||||||
|
rpmbuild -ta --sign $(base).tar.gz
|
Loading…
x
Reference in New Issue
Block a user