[package] restore trimble support after update
git-svn-id: svn://svn.openwrt.org/openwrt/packages@17039 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
424fad5b6a
commit
fcb8b49862
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gpsd
|
||||
PKG_VERSION:=2.39
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://download.berlios.de/gpsd/
|
||||
|
55
net/gpsd/patches/101-trimble.patch
Normal file
55
net/gpsd/patches/101-trimble.patch
Normal file
@ -0,0 +1,55 @@
|
||||
diff -urN gpsd-2.39/drivers.c gpsd-2.39.new/drivers.c
|
||||
--- gpsd-2.39/drivers.c 2009-03-18 18:37:56.000000000 +0100
|
||||
+++ gpsd-2.39.new/drivers.c 2009-07-29 00:22:54.000000000 +0200
|
||||
@@ -165,9 +165,13 @@
|
||||
/* probe for the FV-18 -- expect $PFEC,GPint followed by data */
|
||||
(void)nmea_send(session, "$PFEC,GPint");
|
||||
break;
|
||||
+ case 3:
|
||||
+ /* probe for the Trimble Copernicus */
|
||||
+ (void)nmea_send(session->gpsdata.gps_fd, "$PTNLSNM,0139,01");
|
||||
+ break;
|
||||
#endif /* NMEA_ENABLE */
|
||||
#ifdef EVERMORE_ENABLE
|
||||
- case 3:
|
||||
+ case 4:
|
||||
/* Enable checksum and GGA(1s), GLL(0s), GSA(1s), GSV(1s), RMC(1s), VTG(0s), PEMT101(1s) */
|
||||
/* EverMore will reply with: \x10\x02\x04\x38\x8E\xC6\x10\x03 */
|
||||
(void)gpsd_write(session,
|
||||
@@ -175,31 +179,31 @@
|
||||
break;
|
||||
#endif /* EVERMORE_ENABLE */
|
||||
#ifdef ITRAX_ENABLE
|
||||
- case 4:
|
||||
+ case 5:
|
||||
/* probe for iTrax, looking for "$PFST,OK" */
|
||||
(void)nmea_send(session, "$PFST");
|
||||
break;
|
||||
#endif /* ITRAX_ENABLE */
|
||||
#ifdef GPSCLOCK_ENABLE
|
||||
- case 5:
|
||||
+ case 6:
|
||||
/* probe for Furuno Electric GH-79L4-N (GPSClock); expect $PFEC,GPssd */
|
||||
(void)nmea_send(session, "$PFEC,GPsrq");
|
||||
break;
|
||||
#endif /* GPSCLOCK_ENABLE */
|
||||
#ifdef ASHTECH_ENABLE
|
||||
- case 6:
|
||||
+ case 7:
|
||||
/* probe for Ashtech -- expect $PASHR,RID */
|
||||
(void)nmea_send(session, "$PASHQ,RID");
|
||||
break;
|
||||
#endif /* ASHTECH_ENABLE */
|
||||
#ifdef UBX_ENABLE
|
||||
- case 7:
|
||||
+ case 8:
|
||||
/* probe for UBX -- query software version */
|
||||
(void)ubx_write(session, 0x0au, 0x04, NULL, 0);
|
||||
break;
|
||||
#endif /* UBX_ENABLE */
|
||||
#ifdef MKT3301_ENABLE
|
||||
- case 8:
|
||||
+ case 9:
|
||||
/* probe for MKT-3301 -- expect $PMTK705 */
|
||||
(void)nmea_send(session, "$PMTK605");
|
||||
break;
|
40
net/gpsd/patches/102-no_rej.patch
Normal file
40
net/gpsd/patches/102-no_rej.patch
Normal file
@ -0,0 +1,40 @@
|
||||
diff -urN gpsd-2.39/packaging/gpsd.spec.in.rej gpsd-2.39.new/packaging/gpsd.spec.in.rej
|
||||
--- gpsd-2.39/packaging/gpsd.spec.in.rej 2009-03-17 14:45:02.000000000 +0100
|
||||
+++ gpsd-2.39.new/packaging/gpsd.spec.in.rej 1970-01-01 01:00:00.000000000 +0100
|
||||
@@ -1,36 +0,0 @@
|
||||
-***************
|
||||
-*** 119,125 ****
|
||||
- %{_mandir}/man1/gpsctl.1*
|
||||
- %{_sysconfdir}/hotplug/usb/gpsd.hotplug
|
||||
- %{_sysconfdir}/hotplug/usb/gpsd.usermap
|
||||
-- %attr(755, root, root) /usr/lib/python*/site-packages/gps.py*
|
||||
- #%{_datadir}/gpsd/dgpsip-servers
|
||||
-
|
||||
- %files -n gpsd-devel
|
||||
---- 115,121 ----
|
||||
- %{_mandir}/man1/gpsctl.1*
|
||||
- %{_sysconfdir}/hotplug/usb/gpsd.hotplug
|
||||
- %{_sysconfdir}/hotplug/usb/gpsd.usermap
|
||||
-+ %attr(755, root, root) %{_libdir}/python*/site-packages/gps.py*
|
||||
- #%{_datadir}/gpsd/dgpsip-servers
|
||||
-
|
||||
- %files -n gpsd-devel
|
||||
-***************
|
||||
-*** 129,136 ****
|
||||
- %attr(755, root, root) %{_bindir}/gpsfake
|
||||
- %attr(755, root, root) %{_bindir}/rtcmdecode
|
||||
- %attr(755, root, root) %{_bindir}/gpsflash
|
||||
-- /usr/lib/python*/site-packages/gpsfake.py*
|
||||
-- /usr/lib/python*/site-packages/gpspacket.so*
|
||||
- %{_includedir}/gps.h
|
||||
- %{_includedir}/libgpsmm.h
|
||||
- %{_includedir}/gpsd.h
|
||||
---- 125,132 ----
|
||||
- %attr(755, root, root) %{_bindir}/gpsfake
|
||||
- %attr(755, root, root) %{_bindir}/rtcmdecode
|
||||
- %attr(755, root, root) %{_bindir}/gpsflash
|
||||
-+ %{_libdir}/python*/site-packages/gpsfake.py*
|
||||
-+ %{_libdir}/python*/site-packages/gpspacket.so*
|
||||
- %{_includedir}/gps.h
|
||||
- %{_includedir}/libgpsmm.h
|
||||
- %{_includedir}/gpsd.h
|
Loading…
x
Reference in New Issue
Block a user