cyrus-sasl: fix compile bug, so that we do not need this ugly workaround introduced in r26541.

git-svn-id: svn://svn.openwrt.org/openwrt/packages@26575 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
hauke 2011-04-10 11:45:15 +00:00
parent 988066e62c
commit fe2d2fffb8
2 changed files with 21 additions and 4 deletions

View File

@ -68,7 +68,8 @@ CONFIGURE_ARGS += \
--without-sqlite \
--without-rc4 \
--without-dmalloc \
--without-sfio
--without-sfio \
--disable-sample
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR)/include \
@ -77,9 +78,6 @@ define Build/Compile
CFLAGS="" \
CPPFLAGS="" \
makemd5
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install || \
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install

View File

@ -0,0 +1,19 @@
--- a/lib/Makefile.in
+++ b/lib/Makefile.in
@@ -176,6 +176,7 @@ SASL_KRB_LIB = @SASL_KRB_LIB@
SASL_MECHS = @SASL_MECHS@
SASL_STATIC_LIBS = @SASL_STATIC_LIBS@
SASL_STATIC_OBJS = @SASL_STATIC_OBJS@
+SASL_STATIC_SRC = $(patsubst %.o, %.c, $(SASL_STATIC_OBJS))
SASL_STATIC_SRCS = @SASL_STATIC_SRCS@
SASL_UTIL_HEADERS_EXTRA = @SASL_UTIL_HEADERS_EXTRA@
SASL_UTIL_LIBS_EXTRA = @SASL_UTIL_LIBS_EXTRA@
@@ -646,7 +647,7 @@ libsasl2.a: libsasl2.la $(SASL_STATIC_OB
rm -f $@
ln -s .libs/$@ $@
-$(SASL_STATIC_OBJS): linksrcs
+$(SASL_STATIC_SRC): linksrcs
linksrcs:
-ln -s $(SASL_STATIC_SRCS) .