packages/utils/triggerhappy/patches/100-fix-LINUX_INPUT_H.patch
jow 7a75faf30a [packages] triggerhappy: fix determination of input.h, remove explicit override (#8990)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@25890 3c298f89-4303-0410-b956-a3cf2f4a3e73
2011-03-06 17:26:48 +00:00

12 lines
416 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -10,7 +10,7 @@ THCMD_COMPS := th-cmd cmdsocket
MAKEDEPEND = $(CC) -M -MG $(CPPFLAGS) -o $*.d $<
-LINUX_INPUT_H := $(shell echo '\#include <linux/input.h>' | $(CC) $(CPPFLAGS) -M -E - | awk 'NR==1 {print $$2}')
+LINUX_INPUT_H := $(shell for i in `echo | $(CC) $(CPPFLAGS) -M -E -include 'linux/input.h' -`; do test -f "$$i" && echo "$$i" && break; done)
all: thd th-cmd man