3ad52c7b56
bundle.o was compiled with incompatible setting resulting in error at linking Solution: add CFLAGS to Makefile and fix it Error found on buildbot for target sunxi Error message: build.linux/tvheadend uses VFP register arguments, ./build.linux/bundle.o does not Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@40699 3c298f89-4303-0410-b956-a3cf2f4a3e73
12 lines
289 B
Diff
12 lines
289 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -282,7 +282,7 @@ include support/${OSENV}.mk
|
|
# Bundle files
|
|
$(BUILDDIR)/bundle.o: $(BUILDDIR)/bundle.c
|
|
@mkdir -p $(dir $@)
|
|
- $(CC) -I${CURDIR}/src -c -o $@ $<
|
|
+ $(CC) $(CFLAGS) -I${CURDIR}/src -c -o $@ $<
|
|
|
|
$(BUILDDIR)/bundle.c:
|
|
@mkdir -p $(dir $@)
|