packages/multimedia/motion/patches/002-honor_cppflags.patch
florian cb89352cd1 Upgrade motion to 3.2.10.1 (#3678)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@11651 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-07-05 12:45:00 +00:00

20 lines
669 B
Diff

--- a/Makefile.in
+++ b/Makefile.in
@@ -32,6 +32,7 @@
################################################################################
CFLAGS = @CFLAGS@ -Wall -DVERSION=\"@PACKAGE_VERSION@\" \
-Dsysconfdir=\"$(sysconfdir)\" -Ddocdir=\"$(docdir)\"
+CPPFLAGS = @CPPFLAGS@
LDFLAGS = @LDFLAGS@
LIBS = @LIBS@
VIDEO_OBJ = @VIDEO@
@@ -119,7 +120,7 @@
################################################################################
$(DEPEND_FILE): *.h $(SRC)
@echo "Generating dependencies, please wait..."
- @$(CC) $(CFLAGS) -M $(SRC) > .tmp
+ @$(CC) $(CFLAGS) $(CPPFLAGS) -M $(SRC) > .tmp
@mv -f .tmp $(DEPEND_FILE)
@echo