packages/lang/python/patches/010-disable_modules_and_ssl.patch
pavlov 4d56260742 update to python 2.5.1, security and bug fixes... clean up the makefile slightly... and refresh the patches
git-svn-id: svn://svn.openwrt.org/openwrt/packages@8239 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-07-30 19:05:55 +00:00

39 lines
1.3 KiB
Diff

Index: Python-2.5.1/setup.py
===================================================================
--- Python-2.5.1.orig/setup.py 2007-07-30 12:55:24.000000000 -0500
+++ Python-2.5.1/setup.py 2007-07-30 12:55:24.000000000 -0500
@@ -15,7 +15,14 @@
from distutils.command.install_lib import install_lib
# This global variable is used to hold the list of modules to be disabled.
-disabled_module_list = []
+try:
+ disabled_module_list = os.environ["PYTHON_DISABLE_MODULES"].split()
+except KeyError:
+ disabled_module_list = []
+try:
+ disable_ssl = os.environ["PYTHON_DISABLE_SSL"]
+except KeyError:
+ disable_ssl = 0
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
@@ -244,6 +251,7 @@
return sys.platform
def detect_modules(self):
+ global disable_ssl
try:
modules_include_dirs = os.environ["PYTHON_MODULES_INCLUDE"].split()
except KeyError:
@@ -538,7 +546,8 @@
] )
if (ssl_incs is not None and
- ssl_libs is not None):
+ ssl_libs is not None and
+ not disable_ssl):
exts.append( Extension('_ssl', ['_ssl.c'],
include_dirs = ssl_incs,
library_dirs = ssl_libs,