packages/lang/python/patches/070-dont-clean-ipkg-install.patch
jow e14733e4ab [packages] python: fix compilation against Linux 3.x (#10197)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29369 3c298f89-4303-0410-b956-a3cf2f4a3e73
2011-11-30 19:47:24 +00:00

22 lines
838 B
Diff

---
Makefile.pre.in | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
@@ -1118,11 +1118,11 @@ TAGS::
# Sanitation targets -- clean leaves libraries, executables and tags
# files, which clobber removes as well
pycremoval:
- find $(srcdir) -name '*.py[co]' -exec rm -f {} ';'
+ find $(srcdir) ! -path './ipkg-install/*' -name '*.py[co]' -exec rm -f {} ';'
clean: pycremoval
- find . -name '*.o' -exec rm -f {} ';'
- find . -name '*.s[ol]' -exec rm -f {} ';'
+ find . ! -path './ipkg-install/*' -name '*.o' -exec rm -f {} ';'
+ find . ! -path './ipkg-install/*' -name '*.s[ol]' -exec rm -f {} ';'
find $(srcdir)/build -name 'fficonfig.h' -exec rm -f {} ';' || true
find $(srcdir)/build -name 'fficonfig.py' -exec rm -f {} ';' || true
-rm -f Lib/lib2to3/*Grammar*.pickle