packages/admin/zabbix/patches/001-cross_compile.patch
hauke c599f49346 Update zabbix to 2.2.2
refresh patch (patch configure.ac instead of .in)
zabbix-agentd tested on wr1043nd
zabbix-* compile tested

zabbix-extra-wifi discovery still not working
(need an suid helper to make ubus calls)

Signed-off-by: Etienne CHAMPETIER <etienne.champetier@free.fr>


git-svn-id: svn://svn.openwrt.org/openwrt/packages@40639 3c298f89-4303-0410-b956-a3cf2f4a3e73
2014-05-01 18:32:49 +00:00

30 lines
700 B
Diff

--- a/configure.ac
+++ b/configure.ac
@@ -805,25 +805,8 @@ dnl ************************************
dnl Check for %qu format (FreeBSD 4.x)
dnl FreeBSD 4.x does not support %llu
-AC_MSG_CHECKING(for long long format)
-AC_TRY_RUN(
-[
-#include <sys/types.h>
-int main()
-{
- uint64_t i;
-
- sscanf("200000000010020", "%qu", &i);
-
- if (i == 200000000010020) return 0;
- else return -1;
-}
-],
-AC_DEFINE(HAVE_LONG_LONG_QU, 1 ,[Define to 1 if format '%qu' exists.])
-AC_MSG_RESULT(yes),
-AC_MSG_RESULT(no))
-
dnl option -rdynamic is needed for readable backtraces
+
AC_MSG_CHECKING(for -rdynamic linking option)
saved_LDFLAGS="$LDFLAGS"
LDFLAGS="-rdynamic $LDFLAGS"