packages/libs/axtls/patches/002-axhttpd_install.patch
nico 0f7636fa73 [packages] axtls: update to 1.2.4, add new axtlswrap (SSL/TLS wrapper)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@21030 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-04-19 09:28:16 +00:00

16 lines
456 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -91,8 +91,11 @@ win32_demo:
install: $(PREFIX) all
cp --no-dereference $(STAGE)/libax* $(PREFIX)/lib
chmod 755 $(PREFIX)/lib/libax*
+ifdef CONFIG_AXHTTPD
+ install -m 755 $(STAGE)/axhttpd $(PREFIX)/bin
+endif
ifdef CONFIG_SAMPLES
- install -m 755 $(STAGE)/ax* $(PREFIX)/bin
+ install -m 755 $(STAGE)/axssl $(PREFIX)/bin
endif
ifdef CONFIG_HTTP_HAS_AUTHORIZATION
install -m 755 $(STAGE)/htpasswd $(PREFIX)/bin