packages/net/znc/patches/003-Reduce_rebuild_time.patch
jogo a9c65a441f packages: znc: update to 0.204
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29875 3c298f89-4303-0410-b956-a3cf2f4a3e73
2012-01-23 15:52:32 +00:00

33 lines
879 B
Diff

From 94aff4c3389111fc85054eb06b40bea26a216d0c Mon Sep 17 00:00:00 2001
From: Jonas Gorski <jonas.gorski+openwrt@gmail.com>
Date: Sat, 16 Apr 2011 05:51:04 +0200
Subject: [PATCH] Don't rebuild everything when the Makefile's timestamp changed
---
Makefile.in | 2 +-
modules/Makefile.in | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
--- a/Makefile.in
+++ b/Makefile.in
@@ -96,7 +96,7 @@ clean:
distclean: clean
rm -rf $(DISTCLEAN)
-%.o: %.cpp Makefile
+%.o: %.cpp
@mkdir -p .depend
$(E) Building $@...
$(Q)$(CXX) $(CXXFLAGS) -c -o $@ $< -MMD -MF .depend/$@.dep
--- a/modules/Makefile.in
+++ b/modules/Makefile.in
@@ -114,7 +114,7 @@ install_datadir:
clean:
rm -rf $(CLEAN)
-%.so: %.cpp Makefile
+%.so: %.cpp
@mkdir -p .depend
@mkdir -p extra
$(E) Building $(if $(filter %extra/,$(dir $<)),extra )module $(notdir $(basename $@))...