packages/utils/bash/patches/002-force-internal-readline.patch
jow c7d9d64113 [packages] bash: force linking against internal libreadline.a, fixes Backfire build on CentOS 5.6
git-svn-id: svn://svn.openwrt.org/openwrt/packages@30653 3c298f89-4303-0410-b956-a3cf2f4a3e73
2012-02-19 18:33:26 +00:00

25 lines
685 B
Diff

--- a/configure
+++ b/configure
@@ -5748,8 +5748,7 @@ _ACEOF
# static version specified as -llibname to override the
# dynamic version
case "${host_os}" in
- darwin[89]*|darwin10*) READLINE_LIB='${READLINE_LIBRARY}' ;;
- *) READLINE_LIB=-lreadline ;;
+ *) READLINE_LIB='${READLINE_LIBRARY}' ;;
esac
fi
else
--- a/configure.in
+++ b/configure.in
@@ -540,8 +540,7 @@ if test $opt_readline = yes; then
# static version specified as -llibname to override the
# dynamic version
case "${host_os}" in
- darwin[[89]]*|darwin10*) READLINE_LIB='${READLINE_LIBRARY}' ;;
- *) READLINE_LIB=-lreadline ;;
+ *) READLINE_LIB='${READLINE_LIBRARY}' ;;
esac
fi
else