[packages] uclibc++: remove conflicting inline declarations
git-svn-id: svn://svn.openwrt.org/openwrt/packages@30953 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
066f726437
commit
505107f9e6
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006-2010 OpenWrt.org
|
||||
# Copyright (C) 2006-2012 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=uclibc++
|
||||
PKG_VERSION:=0.2.2
|
||||
PKG_RELEASE:=3
|
||||
PKG_RELEASE:=4
|
||||
|
||||
PKG_SOURCE:=uClibc++-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://cxx.uclibc.org/src/
|
||||
|
34
libs/uclibc++/patches/010-cstring_conflicts.patch
Normal file
34
libs/uclibc++/patches/010-cstring_conflicts.patch
Normal file
@ -0,0 +1,34 @@
|
||||
--- a/include/cstring
|
||||
+++ b/include/cstring
|
||||
@@ -47,31 +47,6 @@ namespace std{
|
||||
using ::strstr;
|
||||
using ::strtok;
|
||||
using ::strxfrm;
|
||||
-
|
||||
-
|
||||
- //Extra definitions required in c++ spec
|
||||
-
|
||||
-
|
||||
- inline void* memchr(void* s, int c, size_t n){
|
||||
- return memchr(const_cast<const void *>(s), c, n);
|
||||
- }
|
||||
-
|
||||
- inline char* strchr(char* s, int c){
|
||||
- return strchr(const_cast<const char *>(s), c);
|
||||
- }
|
||||
-
|
||||
- inline char* strpbrk(char* s1, const char* s2){
|
||||
- return strpbrk(const_cast<const char *>(s1), s2);
|
||||
- }
|
||||
-
|
||||
- inline char* strrchr(char* s, int c){
|
||||
- return strrchr(const_cast<const char *>(s), c);
|
||||
- }
|
||||
-
|
||||
- inline char* strstr(char* s1, const char* s2){
|
||||
- return strstr(const_cast<const char *>(s1), s2);
|
||||
- }
|
||||
-
|
||||
}
|
||||
|
||||
#endif
|
Loading…
x
Reference in New Issue
Block a user