update lzo, and openvpn to latest versions, fix vtun and tinc for lzo2

git-svn-id: svn://svn.openwrt.org/openwrt/packages@4875 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nbd 2006-09-29 19:11:03 +00:00
parent 6a717fe247
commit d4afae6314
6 changed files with 125 additions and 52 deletions

View File

@ -9,13 +9,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=lzo
PKG_VERSION:=1.08
PKG_VERSION:=2.02
PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.oberhumer.com/opensource/lzo/download/
PKG_MD5SUM:=ab94d3da364c7cbd5b78d76f1875b0f6
PKG_MD5SUM:=6760e5819f4238328709bf93bf10071c
PKG_CAT:=zcat
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@ -72,20 +72,20 @@ endef
define Package/liblzo/install
install -d -m0755 $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblzo.so.* $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblzo2.so.* $(1)/usr/lib
endef
define Build/InstallDev
mkdir -p $(STAGING_DIR)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/lzo*.h $(STAGING_DIR)/usr/include/
$(CP) $(PKG_INSTALL_DIR)/usr/include/lzo $(STAGING_DIR)/usr/include/
mkdir -p $(STAGING_DIR)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblzo.{a,so*} $(STAGING_DIR)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblzo2.{a,so*} $(STAGING_DIR)/usr/lib/
endef
define Build/UninstallDev
rm -rf \
$(STAGING_DIR)/usr/include/lzo*.h \
$(STAGING_DIR)/usr/lib/liblzo.{a,so*}
$(STAGING_DIR)/usr/include/lzo* \
$(STAGING_DIR)/usr/lib/liblzo2.{a,so*}
endef
$(eval $(call BuildPackage,liblzo))

View File

@ -1,43 +0,0 @@
For some reason the lzo autoconf script uses a local macro that does
a test for cross-compiles, and assumes that if the build target name
and the host target name are the same that --host was not specified to
the configure script. In the uClibc buildroot, this is not the case.
--- lzo-1.08/aclocal.m4 2002-07-12 18:31:52.000000000 -0700
+++ lzo-1.08/aclocal.m4.new 2004-03-10 15:32:42.000000000 -0700
@@ -205,12 +205,6 @@
[
AC_REQUIRE([AC_PROG_CC])
-if test "X$cross_compiling" = Xyes; then
- if test "X$build" = "X$host"; then
- AC_MSG_ERROR([you are cross compiling - please use the \`--host=' option])
- fi
-fi
-
])
--- lzo-1.08/configure-dist 2004-03-11 02:18:28.000000000 -0600
+++ lzo-1.08/configure 2004-03-11 02:19:16.000000000 -0600
@@ -2282,13 +2282,13 @@
-if test "X$cross_compiling" = Xyes; then
- if test "X$build" = "X$host"; then
- { { echo "$as_me:$LINENO: error: you are cross compiling - please use the \`--host=' option" >&5
-echo "$as_me: error: you are cross compiling - please use the \`--host=' option" >&2;}
- { (exit 1); exit 1; }; }
- fi
-fi
+#if test "X$cross_compiling" = Xyes; then
+# if test "X$build" = "X$host"; then
+# { { echo "$as_me:$LINENO: error: you are cross compiling - please use the \`--host=' option" >&5
+#echo "$as_me: error: you are cross compiling - please use the \`--host=' option" >&2;}
+# { (exit 1); exit 1; }; }
+# fi
+#fi

View File

@ -35,7 +35,9 @@ endef
define Build/Configure
$(call Build/Configure/Default,--with-kernel=$(LINUX_DIR) \
--with-zlib=$(STAGING_DIR)/usr/)
--with-zlib=$(STAGING_DIR)/usr/ \
--with-lzo-include=$(STAGING_DIR)/usr/include/lzo \
)
endef
define Build/Compile

View File

@ -0,0 +1,73 @@
diff -ru tinc-1.0.4.orig/configure tinc-1.0.4/configure
--- tinc-1.0.4.orig/configure 2005-05-05 04:24:06.000000000 +1000
+++ tinc-1.0.4/configure 2005-11-13 18:34:21.000000000 +1100
@@ -11074,13 +11144,13 @@
done
- echo "$as_me:$LINENO: checking for lzo1x_1_compress in -llzo" >&5
-echo $ECHO_N "checking for lzo1x_1_compress in -llzo... $ECHO_C" >&6
-if test "${ac_cv_lib_lzo_lzo1x_1_compress+set}" = set; then
+ echo "$as_me:$LINENO: checking for lzo1x_1_compress in -llzo2" >&5
+echo $ECHO_N "checking for lzo1x_1_compress in -llzo2... $ECHO_C" >&6
+if test "${ac_cv_lib_lzo2_lzo1x_1_compress+set}" = set; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-llzo $LIBS"
+LIBS="-llzo2 $LIBS"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -11112,7 +11182,8 @@
cat conftest.err >&5
echo "$as_me:$LINENO: \$? = $ac_status" >&5
(exit $ac_status); } &&
- { ac_try='test -z "$ac_c_werror_flag" || test ! -s conftest.err'
+ { ac_try='test -z "$ac_c_werror_flag"
+ || test ! -s conftest.err'
{ (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
(eval $ac_try) 2>&5
ac_status=$?
@@ -11124,21 +11195,21 @@
ac_status=$?
echo "$as_me:$LINENO: \$? = $ac_status" >&5
(exit $ac_status); }; }; then
- ac_cv_lib_lzo_lzo1x_1_compress=yes
+ ac_cv_lib_lzo2_lzo1x_1_compress=yes
else
echo "$as_me: failed program was:" >&5
sed 's/^/| /' conftest.$ac_ext >&5
-ac_cv_lib_lzo_lzo1x_1_compress=no
+ac_cv_lib_lzo2_lzo1x_1_compress=no
fi
rm -f conftest.err conftest.$ac_objext \
conftest$ac_exeext conftest.$ac_ext
LIBS=$ac_check_lib_save_LIBS
fi
-echo "$as_me:$LINENO: result: $ac_cv_lib_lzo_lzo1x_1_compress" >&5
-echo "${ECHO_T}$ac_cv_lib_lzo_lzo1x_1_compress" >&6
-if test $ac_cv_lib_lzo_lzo1x_1_compress = yes; then
- LIBS="$LIBS -llzo"
+echo "$as_me:$LINENO: result: $ac_cv_lib_lzo2_lzo1x_1_compress" >&5
+echo "${ECHO_T}$ac_cv_lib_lzo2_lzo1x_1_compress" >&6
+if test $ac_cv_lib_lzo2_lzo1x_1_compress = yes; then
+ LIBS="$LIBS -llzo2"
else
{ { echo "$as_me:$LINENO: error: \"lzo libraries not found.\"" >&5
echo "$as_me: error: \"lzo libraries not found.\"" >&2;}
diff -ru tinc-1.0.4.orig/m4/lzo.m4 tinc-1.0.4/m4/lzo.m4
--- tinc-1.0.4.orig/m4/lzo.m4 2004-03-25 08:04:27.000000000 +1100
+++ tinc-1.0.4/m4/lzo.m4 2005-11-13 18:38:39.000000000 +1100
@@ -26,8 +26,8 @@
[AC_MSG_ERROR("lzo header files not found."); break]
)
- AC_CHECK_LIB(lzo, lzo1x_1_compress,
- [LIBS="$LIBS -llzo"],
+ AC_CHECK_LIB(lzo2, lzo1x_1_compress,
+ [LIBS="$LIBS -llzo2"],
[AC_MSG_ERROR("lzo libraries not found.")]
)
])

View File

@ -37,7 +37,7 @@ endef
define Build/Configure
$(call Build/Configure/Default,,LIBS="-L$(STAGING_DIR)/usr/lib" \
BLOWFISH_HDR_DIR="$(STAGING_DIR)/usr/include/openssl" \
LZO_HDR_DIR="$(STAGING_DIR)/usr/include" \
LZO_HDR_DIR="$(STAGING_DIR)/usr/include/lzo" \
SSL_HDR_DIR="$(STAGING_DIR)/usr/include/openssl")
endef

View File

@ -0,0 +1,41 @@
diff -ur vtun.old/configure vtun.dev/configure
--- vtun.old/configure 2002-12-20 18:22:15.000000000 +0100
+++ vtun.dev/configure 2006-09-29 21:06:09.000000000 +0200
@@ -2001,14 +2001,14 @@
CPPFLAGS="$CPPFLAGS -I$p"
fi
echo "$ac_t""($dir) yes " 1>&6
- echo $ac_n "checking for lzo1x_decompress in -llzo""... $ac_c" 1>&6
-echo "configure:2006: checking for lzo1x_decompress in -llzo" >&5
+ echo $ac_n "checking for lzo1x_decompress in -llzo2""... $ac_c" 1>&6
+echo "configure:2006: checking for lzo1x_decompress in -llzo2" >&5
ac_lib_var=`echo lzo'_'lzo1x_decompress | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-llzo $LIBS"
+LIBS="-llzo2 $LIBS"
cat > conftest.$ac_ext <<EOF
#line 2014 "configure"
#include "confdefs.h"
@@ -2037,7 +2037,7 @@
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
- LIBS="$LIBS -llzo"
+ LIBS="$LIBS -llzo2"
cat >> confdefs.h <<\EOF
#define HAVE_LZO 1
EOF
diff -ur vtun.old/lfd_lzo.c vtun.dev/lfd_lzo.c
--- vtun.old/lfd_lzo.c 2002-04-25 11:19:50.000000000 +0200
+++ vtun.dev/lfd_lzo.c 2006-09-29 21:09:14.000000000 +0200
@@ -36,6 +36,7 @@
#ifdef HAVE_LZO
#include "lzo1x.h"
+#include "lzoutil.h"
static lzo_byte *zbuf;
static lzo_voidp wmem;